Bug 562538 - Installation DNS problem
Summary: Installation DNS problem
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Radek Vykydal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-07 10:10 UTC by A.J. Werkman
Modified: 2011-06-23 11:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-23 11:44:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description A.J. Werkman 2010-02-07 10:10:40 UTC
Description of problem:
Name resolution in a rawhide network installation fails, when giving a IPv6 DNS address

Version-Release number of selected component (if applicable):
Anaconda 13.25

How reproducible:
Everytime

Steps to Reproduce:
1. Start a network installation
2. In the "Manual TCP/IP configuration screen" give a static IPv4 address and a static IPv6 address
3. In the DNS field give (a) a IPv4 address (b) a IPv6address
  
Actual results:
With a IPv4 DNS address installation continues
With a IPv6 DNS address installation stops with a name resolution error on the installation server name.

Expected results:
IPv6 name resolution should work if a IPv6 DNS address is configured

Additional info:
In general network configuration seems to depend on correct IPv4 addressing. IPv4 addressing is at the moment a "conditio sine qua none".
I also refer to bug #562529

In the "Manual TCP/IP configuration screen" you now can both give IPv6 and IPv4 addresses. But there is only room for one type of default gateway and DNS address. Isn't it a good idea to be able to have a IPv4 and IPv6 field for gateway and DNS-server?

Comment 1 Bug Zapper 2010-03-15 14:26:27 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Radek Vykydal 2011-06-23 11:44:16 UTC
IPv6 name resolution works for me in Fedora 15. Special DNS field for IPv6 is not necessary given multiple addresses (ipv4 or ipv6) separated by comma can be entered. For gateway, we support only one address (ipv4 or ipv6) so it really seems as a good idea to support multiple gateways in similar way, or better have special entry for ipv6 gateway as you suggested. This probably concerns kickstart and boot options too. I'll open a new bug for it.

Comment 3 Radek Vykydal 2011-06-23 11:58:10 UTC
(In reply to comment #2)
> ... I'll open a new bug for it.
Bug #715574


Note You need to log in before you can comment on or make changes to this bug.