Bug 56255 - addresses are not flushed on network stop; dhcpcd is not killed on network stop
addresses are not flushed on network stop; dhcpcd is not killed on network stop
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-14 13:06 EST by Need Real Name
Modified: 2014-03-16 22:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-14 13:06:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-11-14 13:06:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16-3 i686)

Description of problem:
"ip route flush dev [dev]" should be done when network is stopped or
restarted. Not doing so causes various kinds of weird problems when old IP
addresses appear again. This kind of behaviour is most noticeable when both
static & DHCP addresses are switched on the same interface. Currently
scripts try to remove the current IP address from list using "ip addr del"
command, however if you change your interface IP address from DHCP to
static the system will keep the DHCP address even after restart and will
show it in "ifconfig" - that's because the DHCP address would not be
deleted, and the new static IP address will be appended to the list of
addresses, and as result will not show in ifconfig (but will show in "ip
addr").

Also dhcpcd is not killed on "service network stop". Personally I find pump
a better solution as it had useful commands such as pump -R, pump -s.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Configure an interface with static IP, bootproto=static
2. Now run dhcpcd - it will replace the address with a dynamic one
3. Now do service network restart - the main address of the interface will
still be dynamic one, and static IP address will be appended to the list in
"ip addr", but will not be visible in ifconfig.

Actual Results:  Not all of the IP addresses are removed from the interface
during "service network stop".

Expected Results:  All of the IP addresses should be removed from the
interfaces during "service network stop".

Additional info:
Comment 1 Bill Nottingham 2001-11-14 14:51:39 EST
Addresses should be flushed with initscripts-6.40.1-1 or later.

Note You need to log in before you can comment on or make changes to this bug.