Bug 56269 - libcrypto and libssl libraries are in wrong directory and have bad versions
libcrypto and libssl libraries are in wrong directory and have bad versions
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: openssl (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-14 15:04 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-14 15:04:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-11-14 15:04:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4)
Gecko/20011019 Netscape6/6.2

Description of problem:
The term package monkey is often used to describe RPM maintainers,
but RH package monkeys must truly have the IQ of a monkey...

The package openssl-0.9.6b-8 contains the files
  /lib/libcrypto.so.0.9.6b
  /lib/libssl.so.0.9.6b
and the symlinks
  /lib/libcrypto.so.2
  /lib/libssl.so.2

point to these files, respectively.  First of all, where does
the '2' come from in libssl.so.2 and libcrypto.so.2?  These 
files should be called libssl.so.0 and libcrypto.so.0.  

Also, the package openssl-devel-0.9.6b-8 contains the files 
  /usr/lib/libssl.so
  /usr/lib/libcrypto.so

There is no need for the -devel package to contain shared libs
since the base package does.  Why are they in a different directory
(/usr/lib instead of /lib)?

Does RedHat intentionally pull a MicroSoft and try to make their 
distro incompatible with everyone else?  Seriously, why do you 
make it impossible for packages built on other distros to work
on RedHat Linux??

Please fix RedHat linux so that the symlinks libcrypto.so.0 and 
libssl.so.0 exist.  Also, get rid of libcrypto.so.2 and
libssl.so.2, as these have no reason to exist (at least not
until the version of openssl is >= 2.0.0.
  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RedHat 7.2
2.type 'locate libssl' and 'locate libcrypto'
3.Stare in awe at the blatant stupidity that appears before you on your screen.
	

Expected Results:  There should be libcrypto.so.0 and libssl.so.0 symlinks,
and there should not be shared libs for openssl in both
/lib and /usr/lib.

Additional info:
Comment 1 Joe Orton 2001-11-23 11:04:15 EST
The library sonames have changed from 0 through 2 because subsequent release of
OpenSSL are not binary compatible with each other. If we didn't do this, then
applications would break e.g. when users upgraded from 0.9.6 to 0.9.6b.

The -devel package only contains symlinks to the real .so files. If they weren't
there, applications can't link against the shared libraries.

The compatibility issue is not best addressed here - maybe you can try the LSB
effort?

Note You need to log in before you can comment on or make changes to this bug.