Bug 562736 - Wrong DMI structures length: 4760 bytes announced, ia64 only
Wrong DMI structures length: 4760 bytes announced, ia64 only
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-dmidecode (Show other bugs)
5.6
All Linux
low Severity medium
: rc
: ---
Assigned To: Roman Rakus
qe-baseos-daemons
: ZStream
Depends On:
Blocks: 621142 621895 706552
  Show dependency treegraph
 
Reported: 2010-02-08 03:53 EST by Petr Sklenar
Modified: 2015-04-02 06:49 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 621142 (view as bug list)
Environment:
Last Closed: 2013-09-23 07:16:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 1 Petr Sklenar 2010-02-08 03:55:25 EST
package maintainer - David Sommerseth's note from https://bugzilla.redhat.com/show_bug.cgi?id=561485#c8

I've looked into this issue today.  It's a bit confusing, as it seems that the
DMI table information is not agreeing on the real amount of data located in the
DMI table.  I have found exactly the same issue on the same box
(hp-rx6600-03.rhts.eng.bos.redhat.com) using dmidecode-2.10-3.el5.

The issue is that the data read out from BIOS regarding the size of the DMI
table do not match the size expected when decoding it.  The size of the DMI
table which the BIOS reports is 2 bytes smaller than what's needed to be able
to decode this DMI entry.  At the moment, I consider this to be a bug in the
host BIOS.

For the host where I verified this issue on, it affects the DMI type 0x7F (End
of Table mark).  This is not a critical issue.

I have a patch for python-dmidecode which improves the enormous warning log,
which will not duplicate the same log message.  And the information when trying
to decode a DMI entry in such a situation is improved.  In this case with
rhnreg_ks, this warning would only appear once under the "COLLECTED WARNINGS"
section.

Unless the amount of duplicated warning messages are too annoying, I do not see
that this patch should be squeezed in right now for RHEL5.5.  The code is
initially safe against reading outside the DMI table buffer, but warning buffer
in DMI decode can be annoying.

This warning buffer can be analysed by using dmidecode.get_warnings() in
Python, or to clear this buffer by calling dmidecode.clear_warnings().  In this
analysing phase, I would report this error once as a possible hardware issue.
Comment 5 Ludek Smid 2010-08-04 09:04:34 EDT
pm_ack for RHEL 5.5.z (see comment #4).
Comment 10 Alexander Todorov 2011-05-25 04:26:21 EDT
*** Bug 706552 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.