Due to a recent update on Javascript code a full page refresh on your browser might be needed.
Bug 562751 - Unable to upload plugin on RHQ host via WEB UI
Summary: Unable to upload plugin on RHQ host via WEB UI
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RHQ Project
Classification: Other
Component: Plugins
Version: 1.4.0.B01
Hardware: All
OS: Linux
high
high vote
Target Milestone: ---
: ---
Assignee: John Mazzitelli
QA Contact:
URL:
Whiteboard:
Depends On: 558528
Blocks: RHQ_SS_Plugin 563224 jon-sprint10-bugs
TreeView+ depends on / blocked
 
Reported: 2010-02-08 09:41 UTC by spandey
Modified: 2015-04-23 23:55 UTC (History)
4 users (show)

Fixed In Version: 2.4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-12 16:56:33 UTC


Attachments (Terms of Use)

Description spandey 2010-02-08 09:41:39 UTC
Description of problem:


Version-Release number of selected component (if applicable):


Prerequisites 

Properly Configured RHQ host 

Steps To repro : 

1) Login to RHQ host with valid credentials .
2) Open Plugin upload page from following Path.
	Administration => System configuration => plugins = > Server Plugin
3) Press “ADD” button and select the plugin <plugin>.jar from valid location
4) Press UPLOAD button to upload plugin on rhq host.


Expected Result : Plugin should uploaded on RHQ host , and it should visible in plugin installed list after “SCAN FOR UPDATES”


Actual Result : At step 4 Never ending Plugin upload process has been started , 
		 Not able to upload plugin on RHQ host via WEB UI 


Note : Plugin upload from CLI is working fine

Comment 1 John Mazzitelli 2010-02-08 14:57:08 UTC
this needs to be assigned to the person that broke the file upload facility (hint: was not me :)

This used to work flawlessly, until I believe the RichFaces library dependency was upgraded. Since then, I too have been seeing this behavior. We need to a) revert back to the RichFaces library of old or b) get a fix to the RichFaces library (because clearly, the RichFaces component that used to work no longer does).

I don't know why the RichFaces library was upgraded.

Comment 2 John Mazzitelli 2010-02-08 18:27:03 UTC
The RichFaces version I see this with is 3.3.2.SR1

I'm working in the "bundle" branch right now - I merged master on Feb. 3rd - which was 5 days ago. I did not touch the richfaces stuff in the bundle branch - I pulled down whatever master had wrt to the RichFaces stuff. Therefore, I assume master branch has the same problem.

Comment 3 Charles Crouch 2010-02-08 22:35:54 UTC
I just tried this with a build from Master, using RF 3.3.2.GA and it failed in the same way mazz described.

Comment 4 Charles Crouch 2010-02-08 22:37:28 UTC
You can test out the problem by going to http://10.16.120.87:7080/rhq/admin/plugin/plugin-list.xhtml (rhqadmin/rhqadmin) and retrying mazz's steps with any old .jar file

Comment 5 Charles Crouch 2010-02-08 22:49:54 UTC
Added https://jira.jboss.org/jira/browse/RF-8359

Comment 6 John Mazzitelli 2010-05-25 19:11:44 UTC
FWIW, I just tried this and the plugin upload GUI worked again. Should have QA run some quick tests to confirm that our production builds are fine too.

Comment 7 Sudhir D 2010-05-28 13:01:32 UTC
I verified this against Build# 169 Version: 2.4 SNAPSHOT. 

I was able to sussessfully upload the plugin via UI and it was available for enablement. 

Marking this bug as verified.

Comment 8 Corey Welton 2010-08-12 16:56:33 UTC
Mass-closure of verified bugs against JON.


Note You need to log in before you can comment on or make changes to this bug.