Bug 562764 - [abrt] crash in eclipse-platform-1:3.5.1-22.fc12
[abrt] crash in eclipse-platform-1:3.5.1-22.fc12
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
abrt_hash:a3f48852922b0f3554648d367df...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-08 05:43 EST by don gilbert
Modified: 2010-08-23 15:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-23 15:51:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (71.46 KB, text/plain)
2010-02-08 05:43 EST, don gilbert
no flags Details

  None (edit)
Description don gilbert 2010-02-08 05:43:16 EST
abrt 1.0.4 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/eclipse/eclipse
comment: Eclipse has been unstable in fedora 12. I have it running on a fedora 10 machine and a windows machine w/o problems. Some package updates fail on dependency issues with a help file instance for eclipse 3.51. I was using the webtools module when this crash occured; specifically the xsl type component
component: eclipse
executable: /usr/lib/eclipse/eclipse
kernel: 2.6.31.12-174.2.3.fc12.i686.PAE
package: eclipse-platform-1:3.5.1-22.fc12
rating: 3
reason: Process was terminated by signal 6 (Aborted)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1.Open Eclipse
2. Open xsd file
3. Attempt to expand on data type and while attempting to scroll a data type ... crash
Comment 1 don gilbert 2010-02-08 05:43:19 EST
Created attachment 389488 [details]
File: backtrace
Comment 2 Andrew Overholt 2010-02-08 10:47:42 EST
Hi,

(In reply to comment #0)
> Some package updates fail on
> dependency issues with a help file instance for eclipse 3.51.

Please explain what you mean by this.  Is this when doing a yum update?  Or some sort of Eclipse Update Manager installation?

> I was using the
> webtools module when this crash occured; specifically the xsl type component

Can you tell me exactly what you installed?  Since we don't ship webtools in Fedora, I want to install exactly what you did to try to reproduce.
Comment 3 Andrew Overholt 2010-02-17 14:59:20 EST
Do you have any more information here, Don?
Comment 4 don gilbert 2010-02-17 19:48:38 EST
Andrew,

I apologize, I didn't see the 2/8 message and caught today's message while at work.

The webtools module I installed is: 
webtools	http://download.eclipse.org/webtools/updates/	Enabled

I have had more stability issues with F12 than I remember with F6,F8 and F10 combined and the box I installed on is new. Nothing particularly special in the configuration but I have had multiple crashes on FF, TBird, Yum extender, and a few with Eclipse. Stability has been improving with patches on all apps.
When I opened Eclipse to grab the source path it returned the following after attempting software updates:

Cannot complete the install because of a conflicting dependency.
  Software being installed: Eclipse Project SDK 3.5.1.R35x_v20090811-7Q7bAIBPVUBVbKSMTyyfpOteKTem7_g2paS1__z-Rrmf4 (org.eclipse.sdk.feature.group 3.5.1.R35x_v20090811-7Q7bAIBPVUBVbKSMTyyfpOteKTem7_g2paS1__z-Rrmf4)
  Software currently installed: Eclipse Platform 3.5.1 (Eclipse Platform 3.5.1)
  Only one of the following can be installed at once: 
    Eclipse Platform 3.3.201.v200909170800 (org.eclipse.platform 3.3.201.v200909170800)
    Eclipse Platform 3.3.200.v200906111540 (org.eclipse.platform 3.3.200.v200906111540)
    Eclipse Platform 3.3.201.R35x_v20090813 (org.eclipse.platform 3.3.201.R35x_v20090813)
  Cannot satisfy dependency:
    From: Eclipse Platform 3.5.1 (Eclipse Platform 3.5.1)
    To: org.eclipse.platform [3.3.201.R35x_v20090813]
  Cannot satisfy dependency:
    From: Eclipse Platform 3.5.1.R35x_v20090910-9gEeG1_FthkNDSP2odXdThaOu9GFDPn83DGB7 (org.eclipse.platform.feature.group 3.5.1.R35x_v20090910-9gEeG1_FthkNDSP2odXdThaOu9GFDPn83DGB7)
    To: org.eclipse.platform [3.3.201.v200909170800]
  Cannot satisfy dependency:
    From: Eclipse Project SDK 3.5.1.R35x_v20090811-7Q7bAIBPVUBVbKSMTyyfpOteKTem7_g2paS1__z-Rrmf4 (org.eclipse.sdk.feature.group 3.5.1.R35x_v20090811-7Q7bAIBPVUBVbKSMTyyfpOteKTem7_g2paS1__z-Rrmf4)
    To: org.eclipse.platform.feature.group [3.5.1.R35x_v20090910-9gEeG1_FthkNDSP2odXdThaOu9GFDPn83DGB7]

I hope this is useful. ..don
Comment 5 Andrew Overholt 2010-02-18 09:01:49 EST
Hi Don,

You can't update the RPM-installed packages using the Eclipse update manager.  Is that what you were trying to do?

You _can_ install additional plugins and features.

Andrew
Comment 6 don gilbert 2010-02-18 17:15:31 EST
Andrew,

That makes perfect sense and no I wasn't intentionally trying to update the RPM install. I believe the auto-update was turned on in eclipse and I will disable that. I did install the webtools module from the update manager and that has been the application I have been using when eclipse has crashed.

Don

Note You need to log in before you can comment on or make changes to this bug.