Bug 562851 - update to 4.3.5 breaks "Exit Session" dialog
update to 4.3.5 breaks "Exit Session" dialog
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-08 10:23 EST by guybrush
Modified: 2010-02-11 09:35 EST (History)
9 users (show)

See Also:
Fixed In Version: 4.3.5-2.fc11.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-11 09:35:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description guybrush 2010-02-08 10:23:59 EST
After update to 4.3.5 there is no options "Poweroff" and "Reboot" in Exit Session's dialog.
Comment 1 Kevin Kofler 2010-02-08 10:53:36 EST
How are you logging in? GDM? KDM? Something else?
Comment 2 Rex Dieter 2010-02-08 11:22:30 EST
and the usual,
rpm -q kdm gdm kdebase-workspace
please.

As well as, from the session not showing poweroff/reboot, post output of:

qdbus --system org.freedesktop.ConsoleKit \
  /org/freedesktop/ConsoleKit/Manager \
  org.freedesktop.ConsoleKit.Manager.CanStop
Comment 3 Rex Dieter 2010-02-08 11:30:05 EST
and,

rpm -q tigervnc-server freenx

If either of these are installed, it's likely due to 
bug #550013
or
bug #561905  (freenx)
Comment 4 guybrush 2010-02-09 01:29:10 EST
GDM

kdm-4.3.5-2.fc11.i586
gdm-2.26.1-13.fc11.i586
kdebase-workspace-4.3.5-2.fc11.i586

Error: org.freedesktop.DBus.Error.UnknownMethod 
Method "CanStop" with signature "" on interface "org.freedesktop.ConsoleKit.Manager" doesn't exist

tigervnc-server-1.0.0-2.fc11.i586
but i don't use selinux
Comment 5 guybrush 2010-02-09 01:54:01 EST
Also 

Feb  9 09:52:31 localhost dbus-daemon: Rejected send message, 2 matched rules; type="method_call", sender=":1.131" (uid=500 pid=6150 comm="ksmserver --windowmanager kwin ") interface="org.freedesktop.ConsoleKit.Manager" member="CanStop" error name="(unset)" requested_reply=0 destination="org.freedesktop.ConsoleKit" (uid=0 pid=1361 comm="/usr/sbin/console-kit-daemon "))

in /var/log/messages
Comment 6 Kevin Kofler 2010-02-09 08:14:44 EST
Grrr, this is my fault, I thought CanStop is supported in all supported Fedora versions by now, it turns out it's only supported from F12 upwards. I'll fix F11 to disable that check again. Sorry for the breakage.
Comment 7 Fedora Update System 2010-02-09 09:53:57 EST
kdebase-workspace-4.3.5-2.fc11.1 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/kdebase-workspace-4.3.5-2.fc11.1
Comment 8 Fedora Update System 2010-02-11 09:35:04 EST
kdebase-workspace-4.3.5-2.fc11.1 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.