Bug 56292 - bash 'escape' does not work any more
bash 'escape' does not work any more
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: bash (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-15 00:11 EST by Joe Acosta
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-25 21:56:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Acosta 2001-11-15 00:11:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
Not sure if it is a setup issue or what, but it used to be (RH 7.1 and
earlier) that you could hit escape in a terminal shell if you were typing a
program or filename adn it woudl autocomplete it for you.  This does not
happen anymore.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install RH 7.2
2.cd /ho
3.hit the escape key
4. It does nothing and in 7.1 it used to complete the word and make it home.


	

Additional info:
Comment 1 Bernhard Rosenkraenzer 2001-11-15 03:35:44 EST
This feature is called "tab completion" because it's activated by pressing the 
tab key, not escape. ;)

If escape worked for you, that was some local re-mapping of keys; the only 
completion we even supported officially is cd /ho[tab].

Comment 2 Joe Acosta 2001-11-15 12:28:13 EST
What did redhat change then in the mapping of the keys and how do I undo what
you did.  Escape has worked for me on Sun, HP, AIX and up until RH 7.2 Linux as
well.  What do I need to do to change this mapping?
Comment 3 Bernhard Rosenkraenzer 2001-11-15 12:49:20 EST
We did not change this mapping, it has always been tab.
Comment 4 Joe Acosta 2001-11-15 13:59:51 EST
I was using 2.4.14 with Redhat 7.1 and now I am using 2.4.14 with Redhat 7.2. 
Why would I need to compile my kernel?
Comment 5 Joe Acosta 2001-11-15 14:02:25 EST
I think you are missing the point.  It worked before and it should work now, and
the only change was from RH 7.1 to RH 7.2.  There has to be something that
changed in 7.2 that effects the escape key.  What is it and how do I undo it?
Comment 6 Glen Foster 2001-11-15 14:41:28 EST
I'm re-opening this because I can reproduce this.  It takes me two escape-keys
to get the same behavior as one tab-key with a 7.1 system w/ bash.  Sure enough,
I try the same thing on the 7.2 system, and voila!  The escape key feature NO
LONGER WORKS.

Maybe it's still not a bug, but the user has a basis for this report. I'd
recommend to the user to think about using the tab-key anyway, since it's
faster... and I have been told (but not verified) that the other UNIXen
mentioned are supposed to use tab-completion the same way as Linux does.

User DOES have a point, and a reproducible one, at that.
Comment 7 Joe Acosta 2001-11-16 13:24:13 EST
I've been doing some research on this and it seems that this may be a korn shell
feature that made its way into bash?  I use bash on Linux always and this was
there. 

Taken from 
http://www.mcsr.olemiss.edu/unixhelp/shell/cmd1.3.html

Filename completion with the Korn shell

Filename completion is only available if the the environment variables EDITOR
and/or VISUAL are set to either emacs, gmacs or vi. For example:

EDITOR=emacs

The value of the VISUAL variable takes precedence over the value of the EDITOR
variable.
emacs- or gmacs-style file completion

To complete a file or directory name with emacs or gmacs set press the ESC key
twice.

ls -l on<ESC><ESC>line_help

If the filename is not completed enter more characters until the filename can be
uniquely identified.

Directories are shown by the trailing / character.
Comment 8 Joe Acosta 2001-11-16 13:27:11 EST
Some more research turn up that it may be the inputrc used by  bash.  Has this
changed?  What was it in 7.1 and what is it in 7.2?
Comment 9 Joe Acosta 2001-11-17 01:17:58 EST
It seems that adding the following to any users inputrc fixes the issue.
"\e\e": complete
This also does NOT break the tab completion.
Comment 10 Tim Waugh 2002-10-11 07:20:18 EDT
We have never mapped escape like this in any previous release, to my 
knowledge.

Note You need to log in before you can comment on or make changes to this bug.