Bug 56302 - no USB keyboard detected
no USB keyboard detected
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-15 06:15 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-21 11:45:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-11-15 06:15:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0; .NET CLR 
1.0.2914)

Description of problem:
installation starts after reading disc1
dos-prompt screen appears to enter a modus (like expert, text) etc.
at this stage the keyboard works
then anaconda starts an NO entry is possible anymore (mouse dead too).
even when you type in prior to anaconda: "linux updates", which is 
possible, after that anaconda starts and send a prompt "install update 
disk YES or NO". keyboard is dead - one cannot answer.

hardware: compaq PIII, 1000 hz, 393 MB RAM, PS/2 mouse, USB-keyboard
2 hdds: 1x30GB for windows2000 (works fine), 1x30GB for red hat

red hat cannot be used at all.

 



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start red hat installation with disc 1
2. prompt for modus allows an entry (i.e. text)
3. anaconda starts: NO keyboard anymore, mouse dead too.
	

Actual Results:  keyboard test failed
if you proceed with the installation procecc despite, there comes the 
point to enter a root-password. THIS is NOT possible and installation is 
halted. computer must be shut off power.

Expected Results:  keyboard test should allow keyboard entries

Additional info:
Comment 1 Brent Fox 2001-11-20 16:48:36 EST
If you type 'text' at the bootup screen, does the keyboard work during text mode
installation?  

We tested USB keyboards and mice, and they worked for us, but I have seen a few
reports on Compaq hardware with USB devices not working.  What kind of Compaq is it?
Comment 2 Need Real Name 2001-11-21 11:45:30 EST
additional informaton to the compaq pc:
PC133 AGP-4X motherboard from asus type cuv4x-cm,
2 PS2 ports, 2 usb ports, 1 for keyboard (standard)
2 x IDE hdd (each 30 GB)
the boot screen accepts typing in: boot: text, but than no detection after that 
action.

I solved the problem in a practical way. instead of getting lost in lots of 
reports and paperwork taking away my time and stressing me, I bought a new
PS2 standard keyboard ($16), connected it to the PS2 port, unplugged the USB-
keyboard - and you want believe it - IT WORKED. installation sucessful.
but what a long way to go overcome a basic standard service in anaconca not 
considering todays hardware.

anyway - I sratched Redhat meanwhile - becuse linux is to difficult for a 
normal educated user to use: it is impossible for a non-expert to install
and run software, i.e. J2SDK and Forte from Sun or to attach an USB-modem. 
in windows2000 you just klick on install and later you have an icon and are 
able to work on the spot. 

cheers Henry


Comment 3 Ron Hansen 2003-11-08 23:03:54 EST
Seems that I have exactly the same problem - again. Installed RH 9
(2.4.20-20.9), get no response from my USB keyboard after the install
starts. Plugged in a PS/2 keyboard to finish installing and
configuring. Been reading bug reports and searching for answers for a
week now with none of the suggestions fixing my problem. Had the same
problem two years ago when I loaded RH 7.3. The fix was to delete some
file. Wish I would have recorded that file's name! 

Compaq Presario 5000 - 850MHz AMD, 384MB ram, Compaq Internet keyboard
(with lots of extra buttons across the top).

When I unplug the USB keyboard, grub correctly recognizes that the
"compaq internet keyboard" is no longer connected. Plugging it back in
causes grub to correctly recognize that the "compaq internet keyboard"
is connected and pretends to configure it. Of course, I have to press
Enter on my PS/2 keyboard because the USB keyboard doesn't respond. I
CAN use the USB keyboard to select which OS to boot at the boot loader
screen, but it doesn't do anything after that.

If anyone can tell me the correct file to delete I would be very
grateful. My wife wants her PS/2 keyboard back!

Note You need to log in before you can comment on or make changes to this bug.