Bug 56304 - HFS volumes are sometimes unshareable on MacIntosh
Summary: HFS volumes are sometimes unshareable on MacIntosh
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cdrecord (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-15 11:21 UTC by jwitford
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-06 21:41:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to cufre the problem (412 bytes, patch)
2001-11-15 11:23 UTC, jwitford
no flags Details | Diff

Description jwitford 2001-11-15 11:21:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (Win98; U)

Description of problem:
When using mkisofs to create HFS CDROMs the resulting CDROM might not
be shareable when mounted on a MacIntosh.  But sometimes it will be.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. mkisofs -hfs --netatalk -o image .
2.
3.
	

Actual Results:  Appears to work properly.
Volume not visible until CDROM mounted on a MacIntosh.
Often will be unshareable on Mac.


Expected Results:  The CDROM should always be shareable.


Additional info:

I have found the reason and created a patch which cures the problem.
The hfsdirent structure that is used to create the Desktop DB/DF files is not initialized properly.
Depending on what is on the stack the "flags" element will be initialized incorrectly resulting
in locked Desktop DB/DF files which causes the CDROM to be unshareable.

--- mkisofs/desktop.c.sharing	Tue Dec  5 14:25:05 2000
+++ mkisofs/desktop.c	Thu Nov 15 10:48:30 2001
@@ -72,7 +72,7 @@
 	int	end;
 {
 	hfsfile		*hfp;			/* Mac file */
-	hfsdirent	ent;			/* Mac finderinfo */
+	hfsdirent	ent = {0};		/* Mac finderinfo */
 	unsigned short	clps;			/* clump size */
 	unsigned short	blks;			/* blocks in a clump */
 	unsigned char	*blk;			/* user data */

Comment 1 jwitford 2001-11-15 11:23:05 UTC
Created attachment 37583 [details]
Patch to cufre the problem

Comment 2 Mike A. Harris 2002-02-05 07:04:42 UTC
Patch added to rawhide build 1.10-8 of cdrtools.

Thanks for the patch.


Note You need to log in before you can comment on or make changes to this bug.