Bug 563088 - SELinux is preventing /usr/libexec/gdm-session-worker "write" access on /root.
Summary: SELinux is preventing /usr/libexec/gdm-session-worker "write" access on /root.
Keywords:
Status: CLOSED DUPLICATE of bug 543970
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:80789cdca1c...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-09 07:22 UTC by Tortuga
Modified: 2010-02-09 20:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-09 13:46:10 UTC


Attachments (Terms of Use)

Description Tortuga 2010-02-09 07:22:03 UTC
Summary:

SELinux is preventing /usr/libexec/gdm-session-worker "write" access on /root.

Detailed Description:

SELinux denied access requested by gdm-session-wor. It is not expected that this
access is required by gdm-session-wor and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                /root [ dir ]
Source                        gdm-session-wor
Source Path                   /usr/libexec/gdm-session-worker
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gdm-2.28.2-1.fc12
Target RPM Packages           filesystem-2.4.30-2.fc12
Policy RPM                    selinux-policy-3.6.32-78.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31.12-174.2.3.fc12.i686.PAE #1 SMP Mon Jan 18
                              20:06:44 UTC 2010 i686 i686
Alert Count                   4
First Seen                    Sat 06 Feb 2010 06:25:50 AM CLST
Last Seen                     Sat 06 Feb 2010 07:14:41 AM CLST
Local ID                      9cfd9039-0e8a-43fe-b6da-e5b9e81d7a5d
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1265451281.600:28191): avc:  denied  { write } for  pid=1643 comm="gdm-session-wor" name="root" dev=dm-0 ino=81601 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1265451281.600:28191): arch=40000003 syscall=5 success=no exit=-13 a0=87b6ed0 a1=80c2 a2=180 a3=21 items=0 ppid=1585 pid=1643 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="gdm-session-wor" exe="/usr/libexec/gdm-session-worker" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.6.32-78.fc12,catchall,gdm-session-wor,xdm_t,admin_home_t,dir,write
audit2allow suggests:

#============= xdm_t ==============
#!!!! The source type 'xdm_t' can write to a 'dir' of the following types:
# pcscd_var_run_t, var_lock_t, xkb_var_lib_t, xdm_rw_etc_t, root_t, tmp_t, var_t, user_fonts_t, user_tmpfs_t, xdm_spool_t, fonts_cache_t, user_home_dir_t, locale_t, var_auth_t, xserver_tmp_t, tmpfs_t, var_spool_t, user_tmp_t, var_lib_t, var_run_t, auth_cache_t, xdm_tmpfs_t, xserver_log_t, var_log_t, xdm_log_t, pam_var_run_t, xdm_var_lib_t, xdm_var_run_t, xdm_home_t, pam_var_console_t, root_t, nfs_t

allow xdm_t admin_home_t:dir write;

Comment 1 Daniel Walsh 2010-02-09 13:46:10 UTC
Are you trying to login as root?  This is not allowed with SELinux in enforcing mode.

*** This bug has been marked as a duplicate of bug 543970 ***

Comment 2 Tortuga Marble 2010-02-09 20:25:43 UTC
I have modified the files /etc/pam.d/gdm and /etc/pam.d/gdm-password (placing "test quiet" instead "root quiet") to allow I can to login as root. But now I have returned that files to its original formats.


Note You need to log in before you can comment on or make changes to this bug.