Bug 563105 - Cannot pass ethtool offline test inside guest and its network will be down after execution
Cannot pass ethtool offline test inside guest and its network will be down af...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.5
All Linux
low Severity high
: rc
: ---
Assigned To: Michael S. Tsirkin
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier3
  Show dependency treegraph
 
Reported: 2010-02-09 03:57 EST by Yolkfull Chow
Modified: 2013-01-09 17:17 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-17 08:03:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yolkfull Chow 2010-02-09 03:57:08 EST
Description of problem:
Execute command 'ethtool -t eth0 offline' will always fail and guest network will be down after that.


Some info from guest:

# ethtool -i eth0
driver: e1000
version: 7.3.20-k2-NAPI
firmware-version: N/A
bus-info: 0000:00:03.0

`dmesg' output after executing ethtool offline test:

e1000: eth0: reg_pattern_test: pattern test reg 0028 failed: got 0x00000000 expected 0x5A5A5A5A
ADDRCONF(NETDEV_UP): eth0: link is not ready
e1000: eth0: e1000_watchdog_task: NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
eth0: no IPv6 routers present
e1000: eth0: e1000_watchdog_task: NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
eth0: no IPv6 routers present


Version-Release number of selected component (if applicable):
kvm-83-157
NIC model: e1000

How reproducible:
Always

Steps to Reproduce:
1. Start guest:
#/root/devel/autotest/client/tests/kvm/qemu -name vm1 -monitor tcp:0:6001,server,nowait -drive file=/root/devel/autotest/client/tests/kvm/images/RHEL-Server-5.4-64.qcow2,if=ide,boot=on -net nic,vlan=0,model=e1000,macaddr=00:AE:70:05:36:01 -net tap,vlan=0,ifname=e1000_0_6001,script=/root/devel/autotest/client/tests/kvm/scripts/qemu-ifup-switch,downscript=no -m 512 -smp 1 -usbdevice tablet -rtc-td-hack -no-hpet -cpu qemu64,+sse2 -no-kvm-pit-reinjection -vnc :0 &

2. log into the guest, and execute command 'ethtool -t eth0 offline'
3. check network of guest
  
Actual results:
guest network is down

Expected results:
ethtool offline test should pass and network should survive

Additional info:
Comment 4 RHEL Product and Program Management 2011-01-11 15:17:05 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2011-01-11 17:49:39 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 6 Michael S. Tsirkin 2011-01-17 08:03:56 EST
I don't think we care.

Note You need to log in before you can comment on or make changes to this bug.