Bug 56313 - /sbin/poweroff fails with apm=off kernel option
/sbin/poweroff fails with apm=off kernel option
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-15 08:41 EST by Sven Mattisson
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 18:24:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sven Mattisson 2001-11-15 08:41:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
Since resume does not work properly and I couldn't figure out how to avoid
it other than disabling apm in the kernel, I added the option apm=off to
grub.conf.  Now the machine, a Compaq Presario 5670, does not go into sleep
any more.  However, now /sbin/poweroff (via command line entry in terminal
window or logout screens) does not turn off power anymore.  The shutdown
procedure proceeds till "system halted" but then the machine stays in that
mode.  Before adding the kernel option it did power off as one would
expect.  Removing the option makes the computer power off properly again
(but then I'm back to the resume problem).

When installing 7.2 I did a clean install (less user files) and upgraded
disk partitions to EXT3.  I do have two dos partitions.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.add kernel option apm=off to grub.conf
2.reboot
3.power off
	

Actual Results:  After displaying system halted (approximately) power is
not turned off

Expected Results:  power should be turned off

Additional info:
Comment 1 Alan Cox 2003-06-07 18:24:36 EDT
APM handles both so its not a bug

Note You need to log in before you can comment on or make changes to this bug.