Bug 56319 - rationalize session choosing/switchdesk again (switchdesk settings not respected on reunlevel 5 w/ GDM)
Summary: rationalize session choosing/switchdesk again (switchdesk settings not respec...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gdm (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: ia64 Linux
medium
low
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: Triaged
: 83967 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-15 15:51 UTC by Josep L. Guallar-Esteve
Modified: 2007-04-18 16:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-15 21:34:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Josep Guallar-Esteve 2001-11-15 15:51:03 UTC
*test tree re1113.0.IA64
*test case/English/NFS/Everything/GUI
gdm-2.2.3.1-20
switchdesk-3.9.7-2
XFree86-4.1.0-6
Linux dhcp4.perf.redhat.com 2.4.9-13.4smp #1 SMP Mon Nov 12 17:06:14 
EST 2001 ia64 unknown


Description of Problem:

GDM does not respect switchdesk settings.

Steps to Reproduce:
1.  Login in GDM
2. open xterm
3.  run switchdesk
4. select other window manager
5. logout
6. login again


Actual Results:

Default window manager not changed


Expected Results:

Default windows manager changed.


Additional Information:
 
If used from runlevel 3 , it works. But from runlevel 5 it refuses to work. GDM 
bug? switchdesk bug?

Comment 1 Havoc Pennington 2001-11-15 16:35:18 UTC
What session do you choose in gdm? You have to choose "Default" I believe.
How are you running gdm in runlevel 3? Or do you mean startx?

Comment 2 Havoc Pennington 2002-02-11 22:50:13 UTC
Please reopen report if more information is added (specifically what 
session is chosen in gdm)

Comment 3 Josep Guallar-Esteve 2002-02-12 14:16:12 UTC
On runlevel 5, (GDM), it has been tried with both Gnome and KDE  selected as 
default. 

Running Gnome as default, I try the procedure (open xterm, switchdesk, select 
KDE/WindowMaker/...) , logout Gnome, login Default session on GDM.... but it 
opens Gnome!

Then, I try the same procedure, but using KDE as default windowmanager and 
selecting Gnome/WMaker... with switchdesk.

From runlevel 3, I use startx to enter graphic mode. So, when there's no GDM 
involved, switchdesk works. When there's GDM, switchdesk settings get ignored.

Hope is clear now.


Comment 4 Owen Taylor 2003-01-16 21:19:32 UTC
Taking gdm target/blockers.

Comment 5 Owen Taylor 2003-02-11 16:31:19 UTC
*** Bug 83967 has been marked as a duplicate of this bug. ***

Comment 6 Owen Taylor 2003-02-11 19:23:27 UTC
Untargetting.

Comment 7 Owen Taylor 2003-08-29 14:53:39 UTC
This is still something we probably need to look at in the future, though it's
less urgent since switchdesk is pretty much a hidden thing these days.



Comment 8 Ray Strode [halfline] 2004-06-15 21:34:32 UTC
Note this seems to work fine now.


Note You need to log in before you can comment on or make changes to this bug.