Bug 56320 - XFree 4.1.0 crashes randoml on ATI Radeon and MGA2164W
Summary: XFree 4.1.0 crashes randoml on ATI Radeon and MGA2164W
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-15 16:14 UTC by Mark Cuss
Modified: 2007-04-18 16:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-25 10:04:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark Cuss 2001-11-15 16:14:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
I've seen this problem on several different machines.  The X Server 
randomly crashes and restarts.  Sometimes it happens a few times a day, 
and sometimes it runs steady for several days without problem.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
The problem is that it is hard to reproduce - the problem is quite random 
and there doesn't seem to be any specific chain of events that triggers 
it.  Once the XServer crashed when I closed KPackage by clicking on 
the "X" on the top RH side of the Window, but doing the same the a second 
time did not cause a crash.....
	

Additional info:

I looked in the XFree logs on both machines and I couldn't find anything 
to point to the reason for the problems....

Comment 1 Need Real Name 2001-11-17 17:40:34 UTC
I am using Redhat 7.2 i386 on a Compaq Presario 5190 with an ATI Radeon 32mb SDR.
I have used both Xconfigurator and xf86config to configure X.  When I run startx
after configuration, the screen appears distorted and becomes unresponsive
immediately.  From the console, the only solution is to reboot. This is very
aggrevating.

Comment 2 Mike A. Harris 2001-11-17 19:32:28 UTC
Are you running the latest Red Hat updated kernel-2.4.9-13, as well
as other packages that have been updated since 7.2 was released?

Comment 3 Mike A. Harris 2002-01-25 10:04:28 UTC
The latest kernel is 2.4.9-21 now.  XFree86 4.1.0-15 is also released
as erratum.  Please upgrade your system to both, as well as the other
required packages such as Mesa, etc.

I cannot reproduce your problem on any of my systems with several Radeon
cards, so if the problem still exists after upgrading to the current
updated software packages we have released, I strongly suspect it is
buggy hardware.  Check your motherboard manufacturer's website for BIOS
flash ROM updates and apply if they have an update.

Please reopen the bug report if you still experience these problems
after upgrading the above, and supply file attachments of your
X server log, your "messages" log, and your X configuration file.
Use the file attachment link to attach them please.  Also provide
the output of the following commands:

uname -a
lspci -vvv
lspci -n
cat /proc/cpuinfo



Note You need to log in before you can comment on or make changes to this bug.