Bug 56322 - ypbind has problems with bad server hostname
ypbind has problems with bad server hostname
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ypbind (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Ben Levenson
:
: 55229 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-15 11:38 EST by Norm Murray
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-21 16:55:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
original patch as attachment (323 bytes, patch)
2002-03-19 13:01 EST, Issue Tracker
no flags Details | Diff
Final patch (512 bytes, patch)
2002-03-21 16:55 EST, Alexander Larsson
no flags Details | Diff

  None (edit)
Description Norm Murray 2001-11-15 11:38:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10smp i686)

Description of problem:
ypbind will lock if /etc/yp.conf contains an unresolvable server hostname
somewhere other than the last line of the file. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
put a bogus server hostname in /etc/yp.conf

start ypbind

Additional info:

This patch will fix the problem:
--- ypbind-mt-1.8/src/serv_list.c	Mon Aug 13 15:07:22 2001
    ypbind-mt-1.8/src/serv_list.c	Mon Aug 13 15:07:24 2001
@@ -456,6  456,7 @@
 		  log_msg (LOG_ERR, _("gethostbyname: Unknown error"));
 		  break;
 		}
 	      pthread_rdwr_wunlock_np (&domainlock);
 	      return;
 	    }
 	  if (hent->h_addr_list[0] == NULL)
Comment 1 Alexander Larsson 2002-03-19 11:43:18 EST
Parts of the patch seems to be missing.
Comment 2 Issue Tracker 2002-03-19 13:01:18 EST
Created attachment 49026 [details]
original patch as attachment
Comment 3 Alexander Larsson 2002-03-21 10:57:27 EST
*** Bug 55229 has been marked as a duplicate of this bug. ***
Comment 4 Alexander Larsson 2002-03-21 16:54:53 EST
fixed in ypbind-1.10-4.
Comment 5 Alexander Larsson 2002-03-21 16:55:23 EST
Created attachment 49504 [details]
Final patch
Comment 6 Alexander Larsson 2002-03-21 16:56:20 EST
I sent the attached patch to thorsten.

Note You need to log in before you can comment on or make changes to this bug.