Bug 56324 - hisax isdn: fax AT commands fail with sedlbauer card
hisax isdn: fax AT commands fail with sedlbauer card
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
http://www.isdn4linux.de/listarch/isd...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-15 12:00 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-15 12:00:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-11-15 12:00:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [de]C-CCK-MCD DT  (WinNT; U)

Description of problem:
The hisax isdn driver is supposed to support the Sedlbauer fax  pci isdn card. This card is semi-active and supports send and receive 
faxes. With kernel RPM 2.4.2, the original kernel shipped with RH LInux 7.1, it works. With kernel 2.4.9-12 from the latest update, it fails 
with the message in /var/log/messages:

isar recmsg IRQSTA timeout
isar waitrecmsg prog failed

The AT emulator /dev/ttyI* will then not accept fax commands (AT FCLASS fails).


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Take a fresh RedHat 7.1 installation with a Sedlbauer speed fax  PCI card. isdn4k-utils must be installed.
2. Load driver kernel module: insmod hisax type=28
3. Load firmware: /usr/sbin/hisaxctrl HiSax 9 /usr/lib/isdn/ISAR.BIN
4. Use minicom or cu to connect to /dev/ttyI0
5. Enter at fclass=?
	

Actual Results:  
0,8
OK

(missing "1")

Expected Results:  
0,1,8
OK

("1" indicating fax class 1 operration)

Additional info:

The problem is confirmed by one of the isdn4linux maintainers at the URL given above. The page also contains a small patch which is 
supposed to fix the problem. I haven't tried it myself so far, though

Please apply the patch in the next kernel updates - thanks!
Comment 1 Arjan van de Ven 2001-11-15 12:05:49 EST
Thanks for this report! The patch looks good so I've added it to the kernel tree
for if/when we're doing a new erratum. 
I'll close this as "fixed in rawhide" as the patch is in the tree and it should
appear in rawhide soon...

Note You need to log in before you can comment on or make changes to this bug.