Bug 563376 - Revive from F11 branch: pcmanx-gtk2 - Telnet client designed for BBS browsing
Summary: Revive from F11 branch: pcmanx-gtk2 - Telnet client designed for BBS browsing
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Robin Lee
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-10 01:36 UTC by Chen Lei
Modified: 2010-06-19 02:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-19 02:32:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
robinlee.sysu: fedora-review+
tibbs: fedora-cvs+


Attachments (Terms of Use)

Description Chen Lei 2010-02-10 01:36:20 UTC
Description:

An easy-to-use telnet client mainly targets BBS users.

PCMan X is a newly developed GPL'd version of PCMan, a full-featured
famous BBS client formerly designed for MS Windows only.  It aimed to
be an easy-to-use yet full-featured telnet client facilitating BBS
browsing with the ability to process double-byte characters.

The package is orphaned at fedora 12 Alpha Freeze, I want to maintain it now:
See:https://koji.fedoraproject.org/koji/packageinfo?packageID=2736

SPEC: 
http://dl.dropbox.com/u/1338197/1/pcmanx-gtk2.spec
SRPM:
http://dl.dropbox.com/u/1338197/1/pcmanx-gtk2-0.3.9-1.20100210svn.fc12.src.rpm

Comment 3 Robin Lee 2010-06-06 05:20:11 UTC
Wrong URLs?
(In reply to comment #2)
> Disable xulrunner plugin by default
> 
> SPEC: 
> https://dl-web.dropbox.com/u/1338197/1/pcmanx-gtk2.spec
> SRPM:
> https://dl-web.dropbox.com/u/1338197/1/pcmanx-gtk2-0.3.9-5.20100601svn.fc13.src.rpm

Comment 4 Robin Lee 2010-06-11 15:05:53 UTC
This is an old package and the spec file is well-structured.

But it failed to build a binary package: https://koji.fedoraproject.org/koji/taskinfo?taskID=2244897
The %configure command should be something like:
%configure --enable-libnotify \
    --enable-wget \
    --enable-iplookup \
    --enable-proxy %{?_with_plugin:--enable-plugin}


The fact that the plugin is disabled should be recorded in %changelog .
And please change the release number every time you modify your spec file.

And some comments should be added on why the plugin is disabled but the building code remains in the spec file.

Requires(post):     /sbin/ldconfig
Requires(postun):   /sbin/ldconfig
The above lines are not necessary.

Though the plugin is now prevented from building, the naming of it is not good. Maybe 'mozilla-pcmanx' is better, with respect to existing similar packages.

Comment 5 Chen Lei 2010-06-12 10:22:53 UTC
(In reply to comment #4)
> This is an old package and the spec file is well-structured.
> But it failed to build a binary package:
> https://koji.fedoraproject.org/koji/taskinfo?taskID=2244897
> The %configure command should be something like:
> %configure --enable-libnotify \
>     --enable-wget \
>     --enable-iplookup \
>     --enable-proxy %{?_with_plugin:--enable-plugin}
> The fact that the plugin is disabled should be recorded in %changelog .
> And please change the release number every time you modify your spec file.
> And some comments should be added on why the plugin is disabled but the
> building code remains in the spec file.
Will be fixed in next realse

> Requires(post):     /sbin/ldconfig
> Requires(postun):   /sbin/ldconfig
> The above lines are not necessary.
This is still needed, e.g. {_libdir}/libpcmanx.so.0
> Though the plugin is now prevented from building, the naming of it is not good.
> Maybe 'mozilla-pcmanx' is better, with respect to existing similar packages.    

This package is not pure mozilla plugin, it also contain some xulrunner compenents , see %file xulrunner-plugin

Comment 6 Robin Lee 2010-06-12 13:55:44 UTC
(In reply to comment #5)
> > Requires(post):     /sbin/ldconfig
> > Requires(postun):   /sbin/ldconfig
> > The above lines are not necessary.
> This is still needed, e.g. {_libdir}/libpcmanx.so.0
http://fedoraproject.org/wiki/Packaging/ScriptletSnippets#Shared_libraries

"If applicable, the latter way is recommended because doing so will automatically add appropriate dependencies on /sbin/ldconfig to the package"

Comment 7 Chen Lei 2010-06-12 14:18:38 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > > Requires(post):     /sbin/ldconfig
> > > Requires(postun):   /sbin/ldconfig
> > > The above lines are not necessary.
> > This is still needed, e.g. {_libdir}/libpcmanx.so.0
> http://fedoraproject.org/wiki/Packaging/ScriptletSnippets#Shared_libraries
> 
> "If applicable, the latter way is recommended because doing so will
> automatically add appropriate dependencies on /sbin/ldconfig to the package"    

I can't find those lines on spec, maybe you see it from other spec file?

Comment 8 Robin Lee 2010-06-12 14:54:25 UTC
(In reply to comment #7)
> I can't find those lines on spec, maybe you see it from other spec file?    

https://dl-web.dropbox.com/u/1338197/1/pcmanx-gtk2.spec

Line 34 and 35.

Comment 10 Robin Lee 2010-06-14 09:15:28 UTC
Okay. Rawhide build succeeded: http://koji.fedoraproject.org/koji/taskinfo?taskID=2248524

Now it is approved by cheeselee.

Comment 11 Chen Lei 2010-06-14 09:30:58 UTC
Package Change Request
======================
Package Name: pcmanx-gtk2
New Branches: F-12 F-13
Owners: supercyper

Comment 12 Chen Lei 2010-06-14 09:31:17 UTC
(In reply to comment #10)
> Okay. Rawhide build succeeded:
> http://koji.fedoraproject.org/koji/taskinfo?taskID=2248524
> 
> Now it is approved by cheeselee.    

Thanks for the review!

Comment 13 Jason Tibbitts 2010-06-18 16:33:06 UTC
I believe I've unretired the package and set the ownership properly.  Please let me know if something doesn't work properly.

Comment 14 Chen Lei 2010-06-19 02:32:24 UTC
(In reply to comment #13)
> I believe I've unretired the package and set the ownership properly.  Please
> let me know if something doesn't work properly.    

built pcmanx-gtk2 on koji successfully , thanks.


Note You need to log in before you can comment on or make changes to this bug.