Bug 563463 (CVE-2010-0419) - CVE-2010-0419 kvm: emulator privilege escalation segment selector check
Summary: CVE-2010-0419 kvm: emulator privilege escalation segment selector check
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2010-0419
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 563464 563465 563466 563468
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-10 10:26 UTC by Petr Matousek
Modified: 2019-09-29 12:34 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-05 19:57:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2010:0126 normal SHIPPED_LIVE Important: kvm security and bug fix update 2010-03-01 19:23:38 UTC
Red Hat Product Errata RHSA-2010:0172 normal SHIPPED_LIVE Important: rhev-hypervisor security and bug fix update 2010-03-24 15:46:46 UTC

Description Petr Matousek 2010-02-10 10:26:47 UTC
Paolo Bonzini found a bug in KVM that can be used to bypass proper permission
checking while loading segment selectors. Malicious guest userspace process
running in SMP guest can trick the emulator into loading kernel segment selector
if it has access to IO port or MMIO region. To do so it should run legitimate
instruction that does IO and will cause vcpu to enter emulator in one thread and
replace this instruction to kernel selector loading one from another thread. If
instruction is replaced after KVM entered emulator, but before instruction is
fetched emulator will be tricked to execute privileged instruction without
permission checking.

Comment 4 errata-xmlrpc 2010-03-01 19:23:46 UTC
This issue has been addressed in following products:

  Red Hat Enterprise Linux 5

Via RHSA-2010:0126 https://rhn.redhat.com/errata/RHSA-2010-0126.html

Comment 5 errata-xmlrpc 2010-03-24 15:46:57 UTC
This issue has been addressed in following products:

  Red Hat Enterprise Virtualization for RHEL-5

Via RHSA-2010:0172 https://rhn.redhat.com/errata/RHSA-2010-0172.html


Note You need to log in before you can comment on or make changes to this bug.