Bug 563503 - Please update to usb_modeswitch 1.1.0
Please update to usb_modeswitch 1.1.0
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: usb_modeswitch (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Huzaifa S. Sidhpurwala
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-10 08:05 EST by David Woodhouse
Modified: 2010-05-12 00:31 EDT (History)
9 users (show)

See Also:
Fixed In Version: usb_modeswitch-1.1.2-3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-28 05:12:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
usb_modeswitch.spec (3.20 KB, text/plain)
2010-02-24 17:58 EST, Peter Hutterer
no flags Details

  None (edit)
Description David Woodhouse 2010-02-10 08:05:02 EST
This will allow usb_modeswitch to be triggered automatically from udev for appropriate devices.
Comment 1 Peter Hutterer 2010-02-24 17:58:21 EST
Created attachment 396178 [details]
usb_modeswitch.spec

Updated spec file to work with 1.1.0 and the udev rules integration.

The upstream makefile is a bit quirky, the spec file somewhat reflects that. Also, the tarball has been renamed to usb-modeswitch-version.tar.gz

Aside from the udev integration, the database for supported devices has been extended so many newer devices will work that previously haven't.
Comment 2 Peter Hutterer 2010-02-25 18:53:38 EST
An additional Requires for tcl is needed as I found out yesterday when testing on a different box.
Comment 3 Huzaifa S. Sidhpurwala 2010-03-04 23:09:54 EST
Hi Peter,
I have taken over the usb_modeswitch.
I have upgraded the rpm in devel.
My approach is to split the package in two parts
the modeswitch and the data rpms.

Would be great if you could go through that.

Thanks.
Comment 4 Josua Dietze 2010-03-07 05:15:30 EST
Hi Huzaifa, Peter,

if you have comments or questions regarding the original source package of usb-modeswitch (Makefile etc.), don't hesitate to contact me.

The source pack of version 1.1.0 was configured in close cooperation with the maintainer of the Debian package to minimize the need of tampering around with the 'upstream tarball' when packaging.

I'm neither a deb nor a rpm guru, so I will gladly accept your advice.

BTW, the Debian package does the same split between data and binary.


Josua

(Author USB_ModeSwitch)
Comment 5 Peter Hutterer 2010-03-07 20:23:02 EST
(In reply to comment #3)
> I have taken over the usb_modeswitch.
> I have upgraded the rpm in devel.

thank you!
Note that I can't test the package since the 3G modem wasn't actually mine, I had to set it up for a friend. not sure when I get my hands on the modem again.
Just a comments regarding the spec file: define should be global these days.
other than that, it looks good to me.


(In reply to comment #4)
> if you have comments or questions regarding the original source package of
> usb-modeswitch (Makefile etc.), don't hesitate to contact me.

I think the easiest would be to autotool the lot, that way dependency checking and the paths to install everything can be tweaked through configure options. It may seem irritating at first, but once the setup is there it needs very little maintainance. I'll send you the patches once I've finished with it.
Comment 6 Josua Dietze 2010-03-08 07:34:25 EST
(In reply to comment #5)
> I think the easiest would be to autotool the lot, that way dependency checking
> and the paths to install everything can be tweaked through configure options.
> It may seem irritating at first, but once the setup is there it needs very
> little maintainance. I'll send you the patches once I've finished with it.    

Well, as you may have guessed, I was shying away from autotool for this tiny project. But if you think packaging will be easier this way, I'll give it a try.
Comment 7 David Woodhouse 2010-03-08 08:00:00 EST
Ew, please don't propagate autocrap -- it really shouldn't be necessary.
Comment 8 Lapo Calamandrei 2010-04-19 06:23:30 EDT
Please update the package on fedora 13 as well, it still ships 1.0.5 which doesn't work for my huwaei e122. It works nicelly using rawhide rpms (version 1.1.0).
Comment 9 Peter Robinson 2010-04-19 06:59:37 EDT
Yes, it seems that F-13 got missed in all that. Its in F-12 and rawhide which will create upgrade path issues as well.
Comment 10 Huzaifa S. Sidhpurwala 2010-04-19 07:04:15 EDT
Hmm yeah , will do F-13 tomorrow then, sorry for that :)
Comment 11 Lapo Calamandrei 2010-04-19 07:09:39 EDT
Speaking about updating, looks like 1.1.2 is out, with data package separated directly upstream.
Comment 12 Huzaifa S. Sidhpurwala 2010-04-19 07:12:31 EDT
(In reply to comment #11)
> Speaking about updating, looks like 1.1.2 is out, with data package separated
> directly upstream.    

Yes, i spoke with upstream about it and it resulted in the packages being split, i am going to package that soon (perhaps today if i have time ? ).
Comment 13 Fedora Update System 2010-04-21 02:29:23 EDT
usb_modeswitch-data-20100418-2.fc13,usb_modeswitch-1.1.2-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/usb_modeswitch-data-20100418-2.fc13,usb_modeswitch-1.1.2-1.fc13
Comment 14 Fedora Update System 2010-04-21 02:31:47 EDT
usb_modeswitch-1.1.2-1.fc12,usb_modeswitch-data-20100418-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/usb_modeswitch-1.1.2-1.fc12,usb_modeswitch-data-20100418-2.fc12
Comment 15 Fedora Update System 2010-04-21 17:52:16 EDT
usb_modeswitch-data-20100418-2.fc13, usb_modeswitch-1.1.2-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update usb_modeswitch-data usb_modeswitch'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/usb_modeswitch-data-20100418-2.fc13,usb_modeswitch-1.1.2-1.fc13
Comment 16 Fedora Update System 2010-04-21 17:54:26 EDT
usb_modeswitch-1.1.2-1.fc12, usb_modeswitch-data-20100418-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update usb_modeswitch usb_modeswitch-data'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/usb_modeswitch-1.1.2-1.fc12,usb_modeswitch-data-20100418-2.fc12
Comment 17 Nerijus Baliūnas 2010-04-22 15:00:03 EDT
I set EnableLogging=1 in /etc/usb_modeswitch.conf, and in /var/log/usb_modeswitch_5-2:1.0 see:

checking config: /etc/usb_modeswitch.d/19d2:2000
! matched, now switching
 (running command: /usr/sbin/usb_modeswitch -I -W -c /etc/usb_modeswitch.d/19d2:
2000)

But there is no /usr/sbin/usb_modeswitch, it is /usr/bin/usb_modeswitch.
Comment 18 Nerijus Baliūnas 2010-04-22 15:07:29 EDT
The following patch for /lib/udev/usb_modeswitch helps:

--- usb_modeswitch.orig	2010-04-18 16:30:04.000000000 +0300
+++ usb_modeswitch	2010-04-22 22:01:00.808171059 +0300
@@ -49,7 +49,7 @@
 eval file delete d [glob -nocomplain /tmp/gsmmodem_*]
 
 set dbdir	/etc/usb_modeswitch.d
-set bindir	/usr/sbin
+set bindir	/usr/bin
 
 set devList1 {}
 set devList2 {}
Comment 19 Josua Dietze 2010-04-22 15:48:00 EDT
I chose /usr/sbin in the original configuration (upstream). Here is why:

Programs using libusb have to be run as superuser. There is no point making it available to the normal user.

A quote from the "Filesystem Hierarchy Standard" [1]:
"Utilities used for system administration (and other root-only commands) are stored in /sbin, /usr/sbin, and /usr/local/sbin."

Libusb usually sits in /usr/lib, so /usr/sbin was the logical choice.

Josua Dietze


[1] http://www.pathname.com/fhs/pub/fhs-2.3.html
Comment 20 David Woodhouse 2010-04-23 03:00:23 EDT
Indeed. Huzaifa, please don't move things from where upstream put them without a _very_ good reason. Which I can't see in this case. If you drop the usb_modeswitch-dir.patch in the current package, everything should work fine.
Comment 21 Huzaifa S. Sidhpurwala 2010-04-23 03:12:26 EDT
The reason why it is in /usr/bin is due to the fact that it was previously in there, when i took the package.

Anyways i removed the patch. Also am packaging /etc/usb_modeswitch.setup which is needed for manual modeswitching.
Comment 22 Fedora Update System 2010-04-23 03:41:02 EDT
usb_modeswitch-1.1.2-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/usb_modeswitch-1.1.2-3.fc13
Comment 23 Fedora Update System 2010-04-23 03:41:08 EDT
usb_modeswitch-1.1.2-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/usb_modeswitch-1.1.2-3.fc12
Comment 24 Fedora Update System 2010-04-23 18:54:13 EDT
usb_modeswitch-1.1.2-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update usb_modeswitch'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/usb_modeswitch-1.1.2-3.fc13
Comment 25 Fedora Update System 2010-04-23 18:54:32 EDT
usb_modeswitch-1.1.2-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update usb_modeswitch'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/usb_modeswitch-1.1.2-3.fc12
Comment 26 Nerijus Baliūnas 2010-04-24 19:06:45 EDT
Works OK now, thanks.
Comment 27 Fedora Update System 2010-05-10 13:04:13 EDT
usb_modeswitch-1.1.2-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 28 Fedora Update System 2010-05-10 19:46:43 EDT
usb_modeswitch-1.1.2-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 29 Nerijus Baliūnas 2010-05-10 20:59:42 EDT
When doing yum update on F12:

--> Finished Dependency Resolution
Error: Package: usb_modeswitch-1.1.2-3.fc12.i686 (updates)
           Requires: usb_modeswitch-data
 You could try using --skip-broken to work around the problem
Comment 30 Huzaifa S. Sidhpurwala 2010-05-10 22:49:27 EDT
oops i forgot to push the data rpm, will do that today, sorry :)
Comment 31 Nerijus Baliūnas 2010-05-11 20:21:00 EDT
F12 now OK, F11 still not.
Comment 32 Bernie Innocenti 2010-05-12 00:31:17 EDT
(In reply to comment #31)
> F12 now OK, F11 still not.    

Should be fixed now.

Note You need to log in before you can comment on or make changes to this bug.