Bug 563523 - PartitionException: Too many primary partitions.
Summary: PartitionException: Too many primary partitions.
Keywords:
Status: CLOSED DUPLICATE of bug 559907
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard: anaconda_trace_hash:9f00eabfb05970afb...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-10 14:09 UTC by Marian Ganisin
Modified: 2010-04-07 18:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-10 14:25:36 UTC


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (244.13 KB, text/plain)
2010-02-10 14:09 UTC, Marian Ganisin
no flags Details
Attached traceback automatically from anaconda. (253.22 KB, text/plain)
2010-02-25 13:59 UTC, Martin Banas
no flags Details
Attached traceback automatically from anaconda. (200.93 KB, text/plain)
2010-03-01 12:15 UTC, Alexander Todorov
no flags Details
Attached traceback automatically from anaconda. (188.98 KB, text/plain)
2010-03-01 12:29 UTC, Alexander Todorov
no flags Details
Attached traceback automatically from anaconda. (290.65 KB, text/plain)
2010-03-11 06:00 UTC, A S Alam
no flags Details
Attached traceback automatically from anaconda. (300.26 KB, text/plain)
2010-03-30 11:10 UTC, Jan Stodola
no flags Details
Attached traceback automatically from anaconda. (832.61 KB, text/plain)
2010-04-07 18:00 UTC, Jan Stodola
no flags Details

Description Marian Ganisin 2010-02-10 14:09:34 UTC
The following was filed automatically by anaconda:
anaconda 13.21.10 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/parted/disk.py", line 246, in addPartition
    constraint.getPedConstraint())
  File "/usr/lib/python2.6/site-packages/parted/decorators.py", line 30, in localeC
    ret = fn(*args, **kwds)
  File "<string>", line 2, in addPartition
  File "/usr/lib/anaconda/storage/formats/disklabel.py", line 275, in addPartition
    constraint=constraint)
  File "/usr/lib/anaconda/storage/devices.py", line 1254, in create
    self.disk.format.addPartition(self.partedPartition)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 203, in execute
    self.device.create(intf=intf)
  File "/usr/lib/anaconda/storage/devicetree.py", line 675, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 287, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 110, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1308, in nextClicked
    self.anaconda.dispatch.gotoNext()
PartitionException: Too many primary partitions.

Comment 1 Marian Ganisin 2010-02-10 14:09:37 UTC
Created attachment 389998 [details]
Attached traceback automatically from anaconda.

Comment 2 Marian Ganisin 2010-02-10 14:20:12 UTC
Reproducer: manually create 4 partitions.

Comment 3 RHEL Product and Program Management 2010-02-10 14:23:33 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 Chris Lumens 2010-02-10 14:25:36 UTC

*** This bug has been marked as a duplicate of bug 559907 ***

Comment 5 Martin Banas 2010-02-25 13:59:41 UTC
Created attachment 396275 [details]
Attached traceback automatically from anaconda.

Comment 6 Alexander Todorov 2010-03-01 12:15:33 UTC
Created attachment 397050 [details]
Attached traceback automatically from anaconda.

Comment 7 Alexander Todorov 2010-03-01 12:29:42 UTC
Created attachment 397053 [details]
Attached traceback automatically from anaconda.

Comment 8 A S Alam 2010-03-11 06:00:25 UTC
Created attachment 399252 [details]
Attached traceback automatically from anaconda.

Comment 9 Jan Stodola 2010-03-30 11:10:43 UTC
Created attachment 403469 [details]
Attached traceback automatically from anaconda.

Comment 10 Jan Stodola 2010-04-07 18:00:02 UTC
Created attachment 405044 [details]
Attached traceback automatically from anaconda.


Note You need to log in before you can comment on or make changes to this bug.