Bug 563528 - elfutils cfi reading bugs
elfutils cfi reading bugs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: elfutils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Roland McGrath
Fedora Extras Quality Assurance
:
Depends On: 564646
Blocks: StapStaticProbesF13 556944 564429
  Show dependency treegraph
 
Reported: 2010-02-10 09:15 EST by Mark Wielaard
Modified: 2010-03-16 19:17 EDT (History)
2 users (show)

See Also:
Fixed In Version: elfutils-0.145-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 561506
Environment:
Last Closed: 2010-03-08 22:22:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cfi-reading-fixes patch for spec (4.25 KB, patch)
2010-02-15 09:08 EST, Mark Wielaard
no flags Details | Diff

  None (edit)
Description Mark Wielaard 2010-02-10 09:15:37 EST
+++ This bug was initially created as a clone of Bug #561506 +++

There are two bugs in elfutils libdwfl and libdw cfi reading support which impact finding the call frame address as used by systemtap.

commit ee29a31c48e4b1ec606a311cba0a6328ce8ea448
Author: Mark Wielaard <mjw@redhat.com>
Date:   Tue Feb 2 20:44:53 2010 +0100

    libdw/fde.c (intern_fde): Fix length check for sized_augmentation_data.

commit eacdcf3e86653b97932f3d6e35c9271b3f406369
Author: Mark Wielaard <mjw@redhat.com>
Date:   Tue Feb 2 15:45:24 2010 +0100

    Always set bias in dwfl_module_dwarf_cfi() and dwfl_module_eh_cfi().

The first is hard to work around in systemtap itself. The second could be worked around, but since we need the first fix anyway, it would be nicer to just have both issues resolved at the same time.
Comment 1 Mark Wielaard 2010-02-15 09:08:23 EST
Created attachment 394318 [details]
cfi-reading-fixes patch for spec

Patch against elfutils srpm CVS. Builds fine for f12, but blocked on bug #564646 for rawhide.
Comment 2 Fedora Update System 2010-02-23 22:48:09 EST
elfutils-0.145-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/elfutils-0.145-1.fc12
Comment 3 Fedora Update System 2010-02-23 22:48:22 EST
elfutils-0.145-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/elfutils-0.145-1.fc11
Comment 4 Fedora Update System 2010-02-23 22:50:49 EST
elfutils-0.145-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/elfutils-0.145-1.fc13
Comment 5 Fedora Update System 2010-02-25 22:39:46 EST
elfutils-0.145-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update elfutils'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2010-2938
Comment 6 Fedora Update System 2010-02-25 22:40:37 EST
elfutils-0.145-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update elfutils'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-2944
Comment 7 Fedora Update System 2010-03-04 22:36:06 EST
elfutils-0.145-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2010-03-08 22:21:59 EST
elfutils-0.145-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2010-03-16 19:17:10 EDT
elfutils-0.145-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.