Bug 563658 - Tomcat plugin start / stop operations on Windows
Tomcat plugin start / stop operations on Windows
Status: CLOSED WORKSFORME
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
1.3
All Windows
high Severity medium (vote)
: ---
: ---
Assigned To: Stefan Negrea
Mike Foley
:
Depends On:
Blocks: ews1.0.2 rhq_triage
  Show dependency treegraph
 
Reported: 2010-02-10 15:04 EST by Ondřej Žižka
Modified: 2011-10-21 15:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-21 15:54:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondřej Žižka 2010-02-10 15:04:56 EST
Versions:
=========

JON 2.3.0.GA
Tomcat 5 and Tomcat plugin 2.3.0 from EWS 1.0.1
Windows 2003


Steps to Reproduce:
===================

1. Install Tomcat 5 (from the EWS? Not sure about community, but should be the same).
2. Install the Tomcat plugin.
3. Register it in JON.
4. Invoke the Start operation and watch what happens on Windows:
  - startup.bat script is called,
  - Tomcat console window appears, Tomcat starts and runs,
  - but JON still reports the operation as In Progress, then fails after timeout.
  - successive Stop operation fails too.
Comment 1 Ondřej Žižka 2010-02-10 16:25:58 EST
Tomcat version is 5.5.28
Comment 2 Ondřej Žižka 2010-02-10 19:06:03 EST
Stop works when Tomcat was started manually (catalina.bat start).
Comment 3 wes hayutin 2010-02-16 11:55:54 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 4 wes hayutin 2010-02-16 12:01:01 EST
making sure we're not missing any bugs in rhq_triage
Comment 5 Corey Welton 2010-09-30 10:00:31 EDT
jsanda - thoughts?
Comment 6 Charles Crouch 2011-03-08 07:45:29 EST
Needs to be reproduced to see if it is still a problem
Comment 7 Charles Crouch 2011-03-08 08:22:54 EST
Just for reference here are a couple of possibly related bugs:
https://bugzilla.redhat.com/show_bug.cgi?id=584008
https://bugzilla.redhat.com/show_bug.cgi?id=604444

This particular one still needs to be reproduced
Comment 8 Ondřej Žižka 2011-03-15 20:11:02 EDT
Testing on windows over VPN is very troublesome, I got disconnected every few dozens of seconds.

Assigning to Igor. Also sent him a mail about what needs to be done.
Comment 9 Stefan Negrea 2011-10-17 18:45:06 EDT
I am unable to reproduce this issue with Tomcat 5.5.33 (with JMX enabled) on Windows 7. I tried restart, shutdown and start operations; all worked without any problems. The shutdown operation takes considerably longer than start but it shuts the server correctly.

Please retest this issue.

Note You need to log in before you can comment on or make changes to this bug.