Bug 563677 - TypeError: unsupported operand type(s) for *: 'NoneType' and 'float'
Summary: TypeError: unsupported operand type(s) for *: 'NoneType' and 'float'
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 13
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:0afab821f098a3950...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-10 20:57 UTC by James Laska
Modified: 2013-09-02 06:43 UTC (History)
5 users (show)

Fixed In Version: anaconda-13.26-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-07 17:58:23 UTC


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (387.34 KB, text/plain)
2010-02-10 20:57 UTC, James Laska
no flags Details

Description James Laska 2010-02-10 20:57:44 UTC
The following was filed automatically by anaconda:
anaconda 13.25 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/partitioning.py", line 628, in sizeToSectors
    return (size * 1024.0 * 1024.0) / sectorSize
  File "/usr/lib/anaconda/storage/partitioning.py", line 1132, in __init__
    [sizeToSectors(partition.req_max_size, sector_size),
  File "/usr/lib/anaconda/storage/partitioning.py", line 1343, in getDiskChunks
    chunks[i].addRequest(Request(p))
  File "/usr/lib/anaconda/storage/partitioning.py", line 1000, in allocatePartitions
    temp_parts, freespace)
  File "/usr/lib/anaconda/storage/partitioning.py", line 811, in doPartitioning
    allocatePartitions(storage, disks, partitions, free)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1583, in refresh
    doPartitioning(self.storage)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1682, in editPartition
    if self.refresh(justRedraw=not actions):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1640, in editCB
    self.editPartition(device)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1141, in treeActivateCB
    self.editCB()
TypeError: unsupported operand type(s) for *: 'NoneType' and 'float'

Comment 1 James Laska 2010-02-10 20:57:48 UTC
Created attachment 390109 [details]
Attached traceback automatically from anaconda.

Comment 2 James Laska 2010-02-10 20:59:02 UTC
= Steps to reproduce =

1. Perform a default install on a system with 4 disks (virt in this case)
2. After install ... wipe out the start of each disk

for DISK in sda sdb sdc sdd;
do
  dd if=/dev/zero of=/dev/$DISK bs=1024 count=1024
done

3. Initiate a new install on the same system with the same disks
4. Select 'Basic Storage'
5. Choose 'Replace linux partitions'
6. Manually delete all logical volumes and physical volumes
7. Attempt to partition using swap, /boot (ext4)
8. Create / (ext4) and choose to take a maximum of 1 MB
9. Edit the / (ext4) partition and change it to use all remaining free space

Comment 3 Hans de Goede 2010-02-15 09:50:49 UTC
Dave,

Looks like partition.req_max_size is not set. I think you may have already fixed this, not sure though.

Regards,

Hans

Comment 4 Bug Zapper 2010-03-15 14:29:20 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.