Bug 56374 - Registering an existing system
Registering an existing system
Status: CLOSED DEFERRED
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
Jay Turner
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-16 08:27 EST by Mike Chambers
Modified: 2015-01-07 18:52 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-28 12:25:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Chambers 2001-11-16 08:27:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Registering a machine that was previously registered and under the same 
name, it includes it twice even if same system/channel

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run rhn_register
2.View RHN web page
3.Look under systems
	

Actual Results:  When you register your system it adds another system

Expected Results:  It should see if there is a same name system and ask 
what to do because of it.  Such as if to override that system, rename, 
etc..

This way if it's the same one you keep all your preferences and such and 
don't have to reentitle it or anything.

Additional info:

I saw this since RHN began but haven't had to actually try this yet with 
7.2.  But all others so far previously would just add that system to the 
database with the same name, so you would have two of the exact same 
machines on the system and have to delete the old one.

If I wasnt' clear, I mainly mean the "system profile name" of the machine.

I also wasn't sure which part to file this under so this seemed like the 
logical choice.  Please correct it if you prefer under something else.
Comment 1 Thomas Hopfner 2002-03-28 10:06:59 EST
This also affects Skipjack beta. Because of problems with up2date (already
bugzilla-ed) I registered the same system three times.

After this it was not possible to call up2date as it said the system is not
entitled. I then manually deleted two system profiles and entitled the one which
system id was the same as in /etc/sysconfig/rhn/systemid -> up2date worked.

Solution: Before registering a system with RHN there should be a check if the
system is already registered!
Comment 2 Jay Turner 2002-03-28 12:25:27 EST
We are working to come up with a process which will address this.  There's
really no good way to know for sure (without asking) if the profile is destined
to replace an existing profile.  There are some ideas that we are poking around
with, so look forward to something in the future.
Comment 3 Cristian Gafton 2002-04-20 03:02:36 EDT
There are some policies things we need to work out before we can allow a system
profile to be wiped clean using rhn_register.

Basically we have to ask for more credentials before we allow such action (ie,
username and passord), Oftentimes people re-register their system because they
forget their username and password - and asking them for that will not do much
good. On the other hand allowing a system profile to be deleted just because
somebody has access to the systemid file is borderline irresponsible IMHO.

Note You need to log in before you can comment on or make changes to this bug.