Bug 563741 - internal audio gone with KDE 4.4.0-1
internal audio gone with KDE 4.4.0-1
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: kde-4.4
  Show dependency treegraph
 
Reported: 2010-02-10 19:01 EST by Bill McGonigle
Modified: 2011-01-19 04:50 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-11 14:13:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of settings...configure channels (48.95 KB, image/png)
2010-02-11 12:12 EST, Bill McGonigle
no flags Details
screenshot with pa disabled (66.85 KB, image/png)
2010-02-11 13:03 EST, Bill McGonigle
no flags Details

  None (edit)
Description Bill McGonigle 2010-02-10 19:01:52 EST
Description of problem:

 This is on an eeePC 1000HE.  It has internal audio and a headphone jack.  Under KDE 4.3, those show up as two channels in KMix.  In 4.4, there's only a single 'out' and that only controls the headphone jack, internal audio is silent.

Version-Release number of selected component (if applicable):

 4.4.0-1

How reproducible:

 always

Steps to Reproduce:
1. update to KDE 4.4.0-1
  
Actual results:

 no internal sound

Expected results:

  Ideally, tie them together and enable both.  Otherwise, allow them to be used separately.

Additional info:

 pulseaudio-0.9.21-4.fc12.i686
Comment 1 Kevin Kofler 2010-02-10 19:04:33 EST
Does the other device show up under "Settings / Configure channels"? If so, that's normal, the KMix PulseAudio integration defaults to showing only the default device.
Comment 2 Bill McGonigle 2010-02-10 20:20:26 EST
no, sorry, here's what I've got in each area:

tab Playback Devices:
  "Internal Audio Analog Stereo"
tab Capture Devices:
  "Internal Audio Analog Stereo"
tab Playback Streams

Settings ... Configure Channels:
 Available channels : [blank]
 Visible channels: "Event Sounds", "kaffeine: Audio Stream" (currently playing)

Settings... Select Master Channel ... Playback devices:
* Internal Audio Analog Stereo (no other options)

Ah, in alsamixer, the default is now Card: PulseAudio.  I can press F6 and select HDA Intel and then adjust my internal speakers (got set to 0).

I don't know why upgrading KDE would have changed the default there, I didn't used to have to F6 in alsamixer before.  Maybe that was an unrelated change in recent days?  I dunno.

I also now see that I can adjust the volume separately in PulseAudio Volume Control.

So, I think what's going on is that with KDE 4.3 I was controlling HDA Intel with KMix.  And I presume in 4.4 that this has been delegated to PA?  Yes, OK, checking a 4.3 machine with 3 output devices, I see each hardware device as a tab in KMix.

So, from a user perspective, if all output channels are controlled in 4.4 with a single abstract volume slider, then probably all underlying hardware channels that are being abstracted need to be controlled together.  Currently they're de-coupled but the user can't know that without going into the PA config - from the taskbar applet it just looks like there's no sound.  I'm not sure if it makes sense for KMix to enumerate device channels and control them itself or if PA should be able to handle this directly.  It's certainly possible somebody will want to control each channel of a single device individually, but the common case is probably something like this laptop with a switch that mutes the internal when you plug in a headphone jack.
Comment 3 Kevin Kofler 2010-02-10 20:48:03 EST
If you switch to the "Playback devices" tab and then do "Settings / Configure channels", are the other devices still not showing up? Because that's where they're supposed to show up.

To get the old ALSA-level KMix back, see:
https://fedoraproject.org/wiki/Features/KDE_PulseAudio_Integration#Release_Notes
(in short, try: kquitapp kmix && sleep 1 && KMIX_PULSEAUDIO_DISABLE=1 kmix
the above link explains how to make this permanent).

We're still debating whether to ship this feature enabled by default in the official KDE 4.4 updates for F11 and F12.
Comment 4 Kevin Kofler 2010-02-11 08:50:21 EST
Ping?

If you switch to the "Playback devices" tab and then do "Settings / Configure
channels", are the other devices still not showing up? Because that's where
they're supposed to show up. ("Configure channels" is per tab.)
Comment 5 Rex Dieter 2010-02-11 08:56:31 EST
Re: comment #3

Looks like we'll be disabling this feature by setting KMIX_PULSEAUDIO_DISABLE=1 by default in f11/f12 updates, and keep it enabled on f13+
Comment 6 Rex Dieter 2010-02-11 09:31:54 EST
%changelog
* Thu Feb 11 2010 Rex Dieter <rdieter@fedoraproject.org> 4.2-17
- Disable kmix/pulseaudio integration by default (#563741)

%changelog
* Thu Feb 11 2010 Rex Dieter <rdieter@fedoraproject.org> 4.3-17
- Disable kmix/pulseaudio integration by default (#563741)
Comment 7 Kevin Kofler 2010-02-11 09:48:35 EST
I'll keep this open for now as I'm still waiting for an answer to comment #4. If this is not working, there's something we should get fixed for F13.
Comment 8 Bill McGonigle 2010-02-11 12:09:25 EST
(In reply to comment #4)

> If you switch to the "Playback devices" tab and then do "Settings / Configure
> channels", are the other devices still not showing up?

Correct, I'll attach a screenshot.

> ("Configure channels" is per tab.)    

Oh, wow, I never would have guessed that.  This might stand some UI re-factoring for F13.
Comment 9 Bill McGonigle 2010-02-11 12:12:25 EST
Created attachment 390301 [details]
screenshot of settings...configure channels

Also, I've got my desktop up to 4.4 now and I see three playback devices under that tab, but those are three separate bits of hardware, not channels on a single piece of hardware like the laptop.
Comment 10 Bill McGonigle 2010-02-11 13:03:30 EST
Created attachment 390309 [details]
screenshot with pa disabled

All channels shown with 4.4's kmix and KMIX_PULSEAUDIO_DISABLE=1
Comment 11 Kevin Kofler 2010-02-11 14:13:25 EST
Well, you have only 1 piece of hardware on that machine, so it's expected that the PulseAudio-based KMix shows only 1 slider. Unfortunately, PulseAudio hides all the advanced controls from ALSA. (This is something I've complained about a lot, but the PulseAudio developer thinks that's the way to go.)

So this is not really a bug. But we have decided not to enable the KMix PulseAudio integration by default for F11 and F12 updates, so this will be resolved in the official updates (see comment #5 and comment #6).
Comment 12 Bill McGonigle 2010-02-11 15:37:43 EST
So, being unable to control volume with KMix isn't a bug?  Really?

I think one slider is a pretty good idea, but if it's not controlling the underlying hardware, the situation is hopeless for the user.

alsamixer can see the channels, why can't kmix?
Comment 13 Orcan Ogetbil 2010-02-28 19:56:43 EST
Please keep this pulseaudio junk disabled for F13. We have a beautifully working audio setup. No need to taint it with pulseaudio. As it seems it started causing problems from day 1.
Comment 14 Kevin Kofler 2010-02-28 20:02:25 EST
The KMix ALSA backend isn't going away any time soon. If you don't have PulseAudio, you always get the plain old ALSA KMix anyway.


As for the previous post:

> alsamixer can see the channels, why can't kmix?

The PulseAudio backend can't see them because it's a PulseAudio mixer, not an ALSA mixer. KMix can only use one backend at a time at this time, you can use KMIX_PULSEAUDIO_DISABLE to switch.
Comment 15 Orcan Ogetbil 2010-02-28 20:13:50 EST
(In reply to comment #14)
> The KMix ALSA backend isn't going away any time soon. 

I know that. I am saying that pulseaudio should not be the default. Going from an out-of-the-box working audio setup to an out-of-the-box nonworking audio setup will do nothing but frustrate our users.
Comment 16 Kevin Kofler 2010-02-28 20:42:15 EST
PulseAudio works. It doesn't give you access to all the hardware controls and I also don't like that (in fact I think we should find some solution to that, to somehow let people control both the PulseAudio and the ALSA volumes, though PulseAudio's "flat volumes" feature causes some trouble with controlling volumes at ALSA leve), but it's not broken.
Comment 17 Kevin Kofler 2010-02-28 20:43:39 EST
(KMIX_PULSEAUDIO_DISABLE is just a quick workaround, not a proper solution: It's an environment variable, not in the UI, it requires restarting KMix and you can't have a PulseAudio KMix and an ALSA KMix running at the same time as KMix is a KUniqueApplication.)
Comment 18 Orcan Ogetbil 2010-03-01 03:43:37 EST
Yes, the "feature" of hiding controls is a Gnome disease. It is totally against KDE philosophy. I wouldn't push this to the users at least until there is an easy GUI way to switch.

I am giving a friendly warning, so that you guys won't say "nobody warned us :(" in a couple months.
Comment 19 Fabian A. Scherschel 2011-01-19 04:39:21 EST
Is this ever gonna get fixed? AFAICT there is no GUI way of choosing between PA sound cards in KDE. Pretty uncomfortable on a laptop where one might want to plug in a decent audio card via USB.
Comment 20 Kevin Kofler 2011-01-19 04:50:01 EST
Switching between different sound cards is done in System Settings in the Phonon configuration, where you can set the priority for sound devices. When using PA, those priorities are applied to all PA-using applications (including Phonon-using ones), not just Phonon ones.

Note You need to log in before you can comment on or make changes to this bug.