Bug 56382 - Kernel 2.4 will not route to 127 block used by diald proxy interfaces
Summary: Kernel 2.4 will not route to 127 block used by diald proxy interfaces
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-16 17:13 UTC by Carl King
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:48:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Carl King 2001-11-16 17:13:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.2) Gecko/20010726
Netscape6/6.1

Description of problem:
This is actually a problem with the address' used in the PPP/SLIP dialout
module for Linuxconf. It uses 127.0.0.10 and 127.0.0.11 for the local and
remote address entries it creates in the conf files under /var/run. Since
the kernel will not route to these address' diald will not place any calls
when demand dialing is selected. The solution would be to change the
default address' used by Linuxconf to a block that the kernel will route
such as 10.0.0.0. This is not a problem in previous kernels and the change
will not adversely affect previous kernels.

Version-Release number of selected component (if applicable):
Linuxconf 1.25r7


How reproducible:
Always

Steps to Reproduce:
1.Use PPP/SLIP dialout to setup PPP on demand connection
2.verify routes to SLIP proxy interface, "route", ifconfig
3.open lynx to any web page on the internet that should force diald up.
	

Actual Results:  Diald will not diald. Even enabling debug does not produce
any errors because as far as diald is concerned, it is configured correctly. 

Expected Results:  If the kernel would route to 127 block, diald should
open the PPP link via dialout.
This should be a simple fix. Just change the address used by Linuxconf to
create the diald proxy sl0 interface and routes.

Additional info:

Comment 1 Brent Fox 2002-06-05 16:16:21 UTC
Closing because we don't ship linuxconf anymore

Comment 2 Red Hat Bugzilla 2006-02-21 18:48:15 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.