Bug 563856 - Windows 7 (32bit, 64bit) and 2008r2 64bit hvm guests installation failed with blue screen error.
Windows 7 (32bit, 64bit) and 2008r2 64bit hvm guests installation failed with...
Status: CLOSED DUPLICATE of bug 524052
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Xen Maintainance List
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-11 07:08 EST by Qixiang Wan
Modified: 2010-02-11 07:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-11 07:38:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
blue screen (16.34 KB, image/png)
2010-02-11 07:14 EST, Qixiang Wan
no flags Details
windows error recovery page (19.33 KB, image/png)
2010-02-11 07:15 EST, Qixiang Wan
no flags Details
output of dmidecode on host (18.25 KB, text/plain)
2010-02-11 07:19 EST, Qixiang Wan
no flags Details
output of xm dmesg (5.37 KB, text/plain)
2010-02-11 07:19 EST, Qixiang Wan
no flags Details
ouput of dmesg on host (22.01 KB, text/plain)
2010-02-11 07:20 EST, Qixiang Wan
no flags Details
/var/log/message on host (113.05 KB, text/plain)
2010-02-11 07:22 EST, Qixiang Wan
no flags Details

  None (edit)
Description Qixiang Wan 2010-02-11 07:08:55 EST
Description of problem:
When install windows 7 (32bit, 64bit) and 2008r2 64bit as a hvm guest, it will get a blue screen during the installation.

Version-Release number of selected component (if applicable):
kernel-xen-2.6.18-164.el5

How reproducible:
100%

Steps to Reproduce:
1. $ cat win7-32.cfg
maxmem = 1024
memory = 1024
vcpus = 1
builder = "hvm"
kernel = "/usr/lib/xen/boot/hvmloader"
boot = "dc"
pae = 1
acpi = 1
apic = 1
localtime = 0
on_poweroff = "destroy"
on_reboot = "restart"
on_crash = "restart"
sdl = 0
vnc = 1
vncunused = 1
vnclisten = "0.0.0.0"
device_model = "/usr/lib64/xen/bin/qemu-dm"
disk = [ "file:/var/lib/xen/images/win7-64.img,hda,w", "file:/root/iso/win7-64.iso,hdc:cdrom,r"]
vif = [ "mac=00:13:54:33:02:32,bridge=xenbr0,script=vif-bridge" ]

$ qemu-img create  /var/lib/xen/images/win7-64.img -f raw 20G
Formatting '/var/lib/xen/images/win7-64.img', fmt=raw, size=20971520 kB

$ xm create win7-32.cfg
  
Actual results:
The guest will get into windows error recovery page after it reboot to prepare environment setup during installation. After choose "start windows normally", it will get a blue screen.

The defect doesn't happen on kernel-xen-2.6.18-187.el5

Expected results:
The installation should succeed.

Additional info:

The installation for those 3 guests can succeed on kernel-xen-2.6.18-187.el5.

$ cat /boot/grub/grub.conf
...

title Red Hat Enterprise Linux Server (2.6.18-164.el5xen)
	root (hd0,0)
	kernel /xen.gz-2.6.18-164.el5 
	module /vmlinuz-2.6.18-164.el5xen ro root=/dev/VolGroup00/LogVol00 rhgb quiet
	module /initrd-2.6.18-164.el5xen.img
...

$ uname -a
Linux intel-q9400-4-4 2.6.18-164.el5xen #1 SMP Tue Aug 18 15:59:52 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
Comment 1 Qixiang Wan 2010-02-11 07:14:40 EST
Created attachment 390225 [details]
blue screen
Comment 2 Qixiang Wan 2010-02-11 07:15:12 EST
Created attachment 390226 [details]
windows error recovery page
Comment 3 Qixiang Wan 2010-02-11 07:19:16 EST
Created attachment 390228 [details]
output of dmidecode on host
Comment 4 Qixiang Wan 2010-02-11 07:19:59 EST
Created attachment 390229 [details]
output of xm dmesg
Comment 5 Qixiang Wan 2010-02-11 07:20:36 EST
Created attachment 390230 [details]
ouput of dmesg on host
Comment 6 Qixiang Wan 2010-02-11 07:22:38 EST
Created attachment 390231 [details]
/var/log/message on host
Comment 7 Paolo Bonzini 2010-02-11 07:38:53 EST
This is due to the XSAVE/XRSTOR feature.

*** This bug has been marked as a duplicate of bug 524052 ***

Note You need to log in before you can comment on or make changes to this bug.