Bug 563909 - [feature] add garbage collection routine to blkid
[feature] add garbage collection routine to blkid
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: e2fsprogs (Show other bugs)
5.6
All Linux
low Severity medium
: rc
: ---
Assigned To: Eric Sandeen
BaseOS QE - Apps
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-11 10:11 EST by Adam Stokes
Modified: 2012-06-14 08:51 EDT (History)
3 users (show)

See Also:
Fixed In Version: e2fsprogs-1.39-28.el5
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-21 05:07:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Stokes 2010-02-11 10:11:04 EST
Description of problem:
Would like to have garbage collection routine added into RHEL5 e2fsprogs. When running blkid we sometimes see stale mounts within the cache. Of course running blkid -c /dev/null gets around this issue I'm a little worried about runtime when blkid is run against a machine with several hundred disks.

Thanks,
Adam
Comment 2 RHEL Product and Program Management 2010-08-09 15:16:08 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 3 Dave Wysochanski 2011-01-27 17:13:16 EST
This is hopefully a fairly easy backport of these two patches:
commit 7292355283b90f1da3a86713b9f85074da22bb84
Author: Theodore Ts'o <tytso@mit.edu>
Date:   Fri May 18 00:02:35 2007 -0400

    Add new function blkid_gc_cache()
    
    New function which performs a garbage collection pass on the
    /etc/blkid.tab file.
    
    Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>



commit 46100e3f6e21a5eb8fbb4d843d4c7fee368b31f5
Author: Theodore Ts'o <tytso@mit.edu>
Date:   Fri May 18 00:16:02 2007 -0400

    Add -g option to the blkid program to garbage collect the blkid.tab file
    
    Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
Comment 4 Eric Sandeen 2011-02-01 15:50:42 EST
probably also need:

commit 772b89d34212e4b36c2025c80304e166bc25a2f3
Author: Eric Sandeen <sandeen@redhat.com>
Date:   Fri Jun 20 22:32:49 2008 -0500

    blkid: use list_for_each_safe in garbage collection
    
    We need to use list_for_each_safe in case a device gets removed from
    the list during garbage collection.
    
    Also make the manpage slightly more informative about
    what the -g garbage collection option does.
    
    Addresses-Debian-Bug: #487758, #487783
    
    Signed-off-by: Eric Sandeen <sandeen@redhat.com>
    Signed-off-by: Theodore Ts'o <tytso@mit.edu>
Comment 5 Eric Sandeen 2011-02-01 17:10:41 EST
Built & tagged in e2fsprogs-1.39-28.el5
Comment 8 errata-xmlrpc 2011-07-21 05:07:40 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1080.html
Comment 9 errata-xmlrpc 2011-07-21 08:38:23 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1080.html

Note You need to log in before you can comment on or make changes to this bug.