Bug 56396 - quake3 crash at memset
quake3 crash at memset
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.2
athlon Linux
high Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-16 14:16 EST by Need Real Name
Modified: 2016-11-24 10:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-16 14:17:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-11-16 14:16:58 EST
Description of Problem:
With glibc-2.4.4-19-i686 Quake3 Arena crash with sound enabled on signal
11. Sound disabled works ok. glibc-2.4.4-19-i386 works fine with or without
sound. With gdb I've found out it crash is memset function.

Version-Release number of selected component (if applicable):
glibc-2.4.4.-19-i686


How Reproducible:
always

Steps to Reproduce:
1. enable sound
2. run quake3
3. signal 11 is reported

Actual Results:


Expected Results:


Additional Information:
Comment 1 Jakub Jelinek 2001-11-16 14:20:36 EST
If it crashes in memtest, it means somebody passed it a wrong pointer or
correct pointer but too large size so that it fell off the cliff.
If there was a bug in memset, you'd notice it far earlier.
So this looks like a quake3 bug.
Comment 2 Andrew Ferguson 2001-11-18 16:22:56 EST
Quake3 with sound fails with Signal 11 for me with glibc-2.2.4-19 with both the
i386 or i686 versions (this is on an Athlon system). I'm not certain this can be
regarded as strictly a Quake3 bug because using LD_PRELOAD to load a simple
memset() function instead of glibc's causes sound to work. Also, Alan Cox posted
on slashdot that this is probably a glibc optimization bug.

Note You need to log in before you can comment on or make changes to this bug.