This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 564107 - Log level of Sigar failures: Change from DEBUG to ERROR.
Log level of Sigar failures: Change from DEBUG to ERROR.
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
1.3
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: John Mazzitelli
Corey Welton
:
Depends On:
Blocks: ews1.0.2 rhq_triage
  Show dependency treegraph
 
Reported: 2010-02-11 15:52 EST by Ondřej Žižka
Modified: 2011-03-08 07:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-08 07:50:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Agent's log. (316.24 KB, text/plain)
2010-02-11 15:55 EST, Ondřej Žižka
no flags Details

  None (edit)
Description Ondřej Žižka 2010-02-11 15:52:57 EST
Description of problem:

I've been trying to add Tomcat 5.5.28 from EWS 1.0.1 on Windows 2003. Tomcat exposes JMX, but the agent fails to send the information. This is what jshaughn identified as the most likely culprit:

-------------------------
2010-02-11 20:52:06,796 DEBUG [InventoryManager.discovery-1] (org.rhq.core.system.ProcessInfo)- Unexpected error occurred while looking up info for [<unknown>] process with pid [288] - call to getProcExe failed. Did the process die? Cause: org.hyperic.sigar.SigarException: Incorrect function.
-------------------------

"(21:23:19) jshaughn: but really, I think 2000 (minimum), XP (most likely) and Vista are the real targets.  Win7 as well, but that's not yet tested."

As  Windows 2003 is supported ( http://www.jboss.com/pdf/JON_2.3_datasheet.pdf ), I suggest to log it at ERROR level.
Comment 1 Ondřej Žižka 2010-02-11 15:55:01 EST
Created attachment 390346 [details]
Agent's log.
Comment 2 Ondřej Žižka 2010-02-11 18:48:58 EST
Btw, Sigar platforms support:
http://support.hyperic.com/display/SIGAR/Home
Comment 3 wes hayutin 2010-02-16 11:52:32 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 4 wes hayutin 2010-02-16 11:58:16 EST
making sure we're not missing any bugs in rhq_triage
Comment 5 Corey Welton 2010-09-30 09:59:34 EDT
mazz- should be a quick fix, no?
Comment 6 John Mazzitelli 2010-09-30 10:20:39 EDT
we used to have this message at a higher log level but the logs got very noisy so we lowered it to DEBUG. It seems this isn't a rare error condition, sometimes sigar just can't see all the processes and in many cases, this actually isn't an error condition, its just the agent doesn't have perms to view them all.

recommend either we close as WONTFIX since we used to have it this way but chose to change it to DEBUG.
Comment 7 Charles Crouch 2011-03-08 07:50:03 EST
As mazz described in his comment this change in logging was made deliberately, and would not have any functional impact on the operation of the Tomcat plugin. Therefore I'm setting this to WONTFIX. If there is a related issue to Tomcat not being manageable on Win2003 then that needs to be raised as a new issue.

Note You need to log in before you can comment on or make changes to this bug.