Bug 564129 - Usage of zarafa-webaccess causes segmentation fault of httpd (via php-mapi)
Summary: Usage of zarafa-webaccess causes segmentation fault of httpd (via php-mapi)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: zarafa
Version: 11
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Robert Scheck
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-11 21:46 UTC by Robert Scheck
Modified: 2010-03-16 19:34 UTC (History)
3 users (show)

Fixed In Version: zarafa-6.30.10-2.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-26 11:49:21 UTC


Attachments (Terms of Use)
Full backtrace of the core dump (35.71 KB, text/plain)
2010-02-11 21:48 UTC, Robert Scheck
no flags Details
Remerged changeset of Subversion Revision 18968 from 6.40.0 (trunk) to 6.30.10 (2.84 KB, patch)
2010-02-23 21:29 UTC, Robert Scheck
no flags Details | Diff

Description Robert Scheck 2010-02-11 21:46:27 UTC
Description of problem:
Usage of zarafa-webaccess causes segmentation fault of httpd (via php-mapi):

[Thu Feb 11 22:06:13 2010] [notice] core dump file size limit raised to 18446744073709551615 bytes
[Thu Feb 11 22:06:13 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Thu Feb 11 22:06:13 2010] [notice] Digest: generating secret for digest authentication ...
[Thu Feb 11 22:06:13 2010] [notice] Digest: done
[Thu Feb 11 22:06:13 2010] [notice] Apache/2.2.13 (Unix) DAV/2 PHP/5.2.12 mod_ssl/2.2.13 OpenSSL/0.9.8k-fips configured -- resuming normal operations
[Thu Feb 11 22:06:15 2010] [notice] child pid 15933 exit signal Segmentation fault (11), possible coredump in /tmp

Version-Release number of selected component (if applicable):
libmapi-6.30.10-1.fc11.x86_64
zarafa-monitor-6.30.10-1.fc11.x86_64
zarafa-server-6.30.10-1.fc11.x86_64
zarafa-ical-6.30.10-1.fc11.x86_64
php-mapi-6.30.10-1.fc11.x86_64
zarafa-6.30.10-1.fc11.x86_64
zarafa-dagent-6.30.10-1.fc11.x86_64
zarafa-debuginfo-6.30.10-1.fc11.x86_64
zarafa-spooler-6.30.10-1.fc11.x86_64
zarafa-gateway-6.30.10-1.fc11.x86_64
zarafa-utils-6.30.10-1.fc11.x86_64
zarafa-common-6.30.10-1.fc11.x86_64
zarafa-client-6.30.10-1.fc11.x86_64
zarafa-webaccess-6.30.10-1.fc11.noarch

How reproducible:
Everytime, see above, below and the attachment.

Steps to Reproduce:
1. yum install zarafa zarafa-webaccess --enablerepo=testing
2. Configure MySQL
3. service httpd restart
4. Go to http://localhost/webaccess/ and get the error

Actual results:
Usage of zarafa-webaccess causes segmentation fault of httpd (via php-mapi)

Expected results:
No segmentation fault when php-mapi/zarafa-webaccess is used.

Additional info:
I'll attach a full backtrace from the core dump.

Comment 1 Robert Scheck 2010-02-11 21:48:07 UTC
Created attachment 390353 [details]
Full backtrace of the core dump

Comment 2 Robert Scheck 2010-02-12 09:40:23 UTC
I've to correct myself: The crash happens when I try to login into webaccess.
If I come then back again to the login page, the crash happens right away as
it seems, because of the cookie or whatelse knows the session. A simple "cd
/usr/share/zarafa-webaccess && php index.php" works fine. A simple PHP-MAPI script works (connect the Zarafa Server, fetch all calendar entries for today
and show them) without crashing - and that via Apache & PHP. Looks like the
login is doing something worse?!

Comment 3 Robert Scheck 2010-02-22 16:22:46 UTC
The same is happening on Fedora 12.

Comment 4 Robert Scheck 2010-02-23 21:29:18 UTC
Created attachment 395835 [details]
Remerged changeset of Subversion Revision 18968 from 6.40.0 (trunk) to 6.30.10

Comment 5 Fedora Update System 2010-02-23 21:45:12 UTC
zarafa-6.30.10-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/zarafa-6.30.10-2.fc13

Comment 6 Fedora Update System 2010-02-23 21:45:36 UTC
zarafa-6.30.10-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/zarafa-6.30.10-2.fc12

Comment 7 Fedora Update System 2010-02-23 21:46:01 UTC
zarafa-6.30.10-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/zarafa-6.30.10-2.fc11

Comment 8 Fedora Update System 2010-02-23 21:46:22 UTC
zarafa-6.30.10-2.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/zarafa-6.30.10-2.el5

Comment 9 Fedora Update System 2010-02-24 08:00:22 UTC
zarafa-6.30.10-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update zarafa'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F13/FEDORA-2010-2816

Comment 10 Fedora Update System 2010-02-24 17:35:27 UTC
zarafa-6.30.10-2.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update zarafa'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2010-2312

Comment 11 Fedora Update System 2010-02-25 20:15:35 UTC
zarafa-6.30.10-2.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2010-2312

Comment 12 Fedora Update System 2010-02-25 20:18:58 UTC
zarafa-6.30.10-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/F13/FEDORA-2010-2816

Comment 13 Fedora Update System 2010-02-26 03:41:05 UTC
zarafa-6.30.10-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update zarafa'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-2948

Comment 14 Fedora Update System 2010-02-26 03:46:10 UTC
zarafa-6.30.10-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update zarafa'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2010-2958

Comment 15 Fedora Update System 2010-02-26 08:08:23 UTC
zarafa-6.30.10-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/F11/FEDORA-2010-2958

Comment 16 Fedora Update System 2010-02-26 08:09:22 UTC
zarafa-6.30.10-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/F12/FEDORA-2010-2948

Comment 17 Fedora Update System 2010-02-26 11:49:02 UTC
zarafa-6.30.10-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2010-02-27 03:32:25 UTC
zarafa-6.30.10-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2010-02-27 03:48:00 UTC
zarafa-6.30.10-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2010-03-16 19:34:16 UTC
zarafa-6.30.10-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.