Bug 564188 - redhat-release does not include rpm macros required to build packages
Summary: redhat-release does not include rpm macros required to build packages
Keywords:
Status: CLOSED DUPLICATE of bug 481023
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: redhat-release
Version: 5.4
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Daniel Mach
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-11 22:58 UTC by Till Maas
Modified: 2010-02-12 08:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-12 08:29:42 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Till Maas 2010-02-11 22:58:25 UTC
Description of problem:
Currently it is required to use rpms from
http://buildsys.fedoraproject.org/buildgroups/rhel5/i386/
to build RHEL rpms, because macros like %rhel are not defined otherwise.

In Fedora, these macros have been moved into fedora-release:
http://lists.fedoraproject.org/pipermail/devel/2007-June/104640.html

Please either include these macros in redhat-release for RHEL 5 or state that you won't do this, both would help me a lot.

Version-Release number of selected component (if applicable):
redhat-release-5Client-5.4.0.3

This is needed to be added to the %install and %files section to fix this:

%install
mkdir -p $RPM_BUILD_ROOT/etc/rpm/
VERSION%{base_release_version}
printf %s%b "%" "rhel $VERSION\n" >> $RPM_BUILD_ROOT/etc/rpm/macros.disttag
printf %s%b "%" "dist .el$VERSION\n" >> $RPM_BUILD_ROOT/etc/rpm/macros.disttag
printf %s%b "%" "el$VERSION 1\n" >> $RPM_BUILD_ROOT/etc/rpm/macros.disttag
printf %s%b "%" "__arch_install_post /usr/lib/rpm/check-buildroot\n" >> $RPM_BUILD_ROOT/etc/rpm/macros.checkbuild


%files
%defattr(-,root,root)
/etc/rpm/macros.disttag
/etc/rpm/macros.checkbuild

Comment 1 Daniel Mach 2010-02-12 08:29:42 UTC
Till,
we already decided not to add macros to redhat-release in RHEL5.
I recommend you to keep using buildsys-macros.

Closing as duplicate of bz#481023.

*** This bug has been marked as a duplicate of bug 481023 ***


Note You need to log in before you can comment on or make changes to this bug.