Bug 564213 - Traceback setting up the logger in stage2
Summary: Traceback setting up the logger in stage2
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ales Kozumplik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 564269 (view as bug list)
Depends On:
Blocks: F13Alpha, F13AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2010-02-12 00:32 UTC by Jesse Keating
Modified: 2014-09-30 23:38 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-15 13:32:28 UTC


Attachments (Terms of Use)
anaconda traceback (12.95 KB, image/png)
2010-02-12 00:32 UTC, Jesse Keating
no flags Details

Description Jesse Keating 2010-02-12 00:32:30 UTC
Created attachment 390417 [details]
anaconda traceback

I get a traceback and anaconda abort very early on in stage2.  This happens on real hardware, virt, i386 and x86_64, text and graphical.  I've attached the screenshot of the traceback.  This is from the test compose I've done from today's (20100211) rawhide.

Comment 1 Jesse Keating 2010-02-12 00:45:59 UTC
Upon further investigation, it seems that rsyslog cannot start up at boot time, due to a missing //lib/rsyslog/lmnet.so   There were other issues with rsyslog recently so I'm pulling in a newer build and composing with that to see if it gets any better.

Comment 2 Chris Lumens 2010-02-12 00:46:54 UTC

*** This bug has been marked as a duplicate of bug 563348 ***

Comment 3 Jesse Keating 2010-02-12 01:12:06 UTC
I don't think this is a dupe.  The failure case of rsyslog is different than that bug, it doesn't segfault it just can't find a lib it needs.  When pulling in the fix for 563348 it still doesn't fix anaconda.

Comment 4 Jesse Keating 2010-02-12 01:46:04 UTC
Yep, I just verified that we're not getting all of the rsyslog .so files installed for some reason.  Re-opening.

Comment 5 Jesse Keating 2010-02-12 01:58:52 UTC
Patch sent, not really tested though.

Comment 6 Ales Kozumplik 2010-02-12 09:23:25 UTC
*** Bug 564269 has been marked as a duplicate of this bug. ***

Comment 7 Ales Kozumplik 2010-02-12 09:56:50 UTC
Yes,

I can reproduce this on my custom rawhide compose, this is because rsyslog moved its libs between 4.4.1 and 4.4.2.

I am going to use Jesse's patch and see if it works and composes OK before pushing. Switching back to ASSIGNED until then.

Ales

Comment 8 James Laska 2010-02-15 13:32:28 UTC
No longer seeing this with F-13-Alpha-TC2 which includes anaconda-13.26 (http://serverbeach1.fedoraproject.org/pub/alt/stage/13-Alpha.TC2/Fedora/)


Note You need to log in before you can comment on or make changes to this bug.