Bug 564283 - Broadcom BCM57788 not recognised on Dell Inspiron 570
Broadcom BCM57788 not recognised on Dell Inspiron 570
Status: CLOSED DUPLICATE of bug 525966
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-12 04:13 EST by bugzilla
Modified: 2010-04-23 22:54 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-23 22:54:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description bugzilla 2010-02-12 04:13:14 EST
Description of problem:
Broadcom BCM57788 not recognised on Dell Inspiron 570


Version-Release number of selected component (if applicable):
kernel-2.6.31.12-174.2.3.fc12.x86_64
firmware-addon-dell-2.1.2-5.3.fc12.x86_64

How reproducible:
After booting, no NIC is visible. lspci -vvxxx gives the following for the NIC:
02:00.0 Ethernet controller: Broadcom Corporation Device 1691 (rev 01)
        Subsystem: Dell Device 043b
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at feaf0000 (64-bit, non-prefetchable) [size=64K]
        Capabilities: [48] Power Management version 3
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot+,D3cold+)
                Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=1 PME-
        Capabilities: [60] Vendor Specific Information: Len=6c <?>
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
                Address: 1c8805de303d4488  Data: 2018
        Capabilities: [cc] Express (v2) Endpoint, MSI 00
                DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <4us, L1 unlimited
                        ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
                DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
                        RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
                        MaxPayload 128 bytes, MaxReadReq 512 bytes
                DevSta: CorrErr+ UncorrErr- FatalErr- UnsuppReq+ AuxPwr+ TransPend-
                LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <1us, L1 <32us
                        ClockPM+ Surprise- LLActRep- BwNot-
                LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
                        ExtSynch- ClockPM+ AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
                DevCap2: Completion Timeout: Range ABCD, TimeoutDis+
                DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-
                LnkCtl2: Target Link Speed: 2.5GT/s, EnterCompliance- SpeedDis-, Selectable De-emphasis: -6dB
                         Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
                         Compliance De-emphasis: -6dB
                LnkSta2: Current De-emphasis Level: -6dB
        Capabilities: [100 v1] Advanced Error Reporting
                UESta:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
                UEMsk:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
                UESvrt: DLP+ SDES+ TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
                CESta:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
                CEMsk:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
                AERCap: First Error Pointer: 00, GenCap+ CGenEn- ChkCap+ ChkEn-
        Capabilities: [13c v1] Virtual Channel
                Caps:   LPEVC=0 RefClk=100ns PATEntrySize=0
                Arb:    Fixed- WRR32- WRR64- WRR128- 100ns- - - onfig- TableOffset=0
                Ctrl:   ArbSelect=Fixed
                Status: InProgress-
                VC0:    Caps:   PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
                        Arb:    Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256- Fixed- RR32-
                        Ctrl:   Enable+ ID=0 ArbSelect=Fixed TC/VC=ff
                        Status: NegoPending- InProgress-
        Capabilities: [160 v1] Device Serial Number 00-26-2d-ff-fe-17-c3-68
        Capabilities: [16c v1] Power Budgeting <?>
00: e4 14 91 16 06 01 10 00 01 00 00 02 10 00 00 00
10: 04 00 af fe 00 00 00 00 00 00 00 00 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 28 10 3b 04
30: 00 00 00 00 48 00 00 00 00 00 00 00 0b 01 00 00

'device 1691' is a BCM57788 according to http://cateee.net/lkddb/web-lkddb/TIGON3.html, and this NIC should be supported by the tg3 driver. However, no 'Kernel modules' line is visible in the lspci output.

Steps to Reproduce:
1. Buy a Dell Inspiron 570 (I bought mine 3 weeks ago, http://configure.euro.dell.com/dellstore/config.aspx?oc=d005736&c=nl&l=nl&s=dhs&cs=nldhs1&kc=inspiron-570 with default settings)
2. Install F12
3. Check the interface status
  
Actual results:
No NIC visible

Expected results:
NIC visible

Additional info:
I'm not sure if this is a kernel problem, a firmware-addon-dell problem, or something else.
Comment 1 Benjamin Kahn 2010-04-23 22:41:25 EDT
I'm having the same problem on a Dell 580s system with the same card.

By running:
insmod /lib/modules/2.6.32.11-99.fc12.x86_64/kernel/drivers/net/phy/broadcom.ko
insmod /lib/modules/2.6.32.11-99.fc12.x86_64/kernel/drivers/net/tg3.ko
ifconfig eth0 up
dhclient eth0

I get an IP address.  So the driver is present, at least in this updated kernel.  However, I have not yet gotten it to load on boot or display through Network Manager.
Comment 2 Benjamin Kahn 2010-04-23 22:54:22 EDT

*** This bug has been marked as a duplicate of bug 525966 ***

Note You need to log in before you can comment on or make changes to this bug.