Bug 56429 - ifconfig print every isdn device twice but differently
ifconfig print every isdn device twice but differently
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: net-tools (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-17 14:46 EST by Bernd Bartmann
Modified: 2015-03-04 20:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-02 09:35:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of ifconfig, route and ip command (17.39 KB, text/plain)
2001-11-17 14:48 EST, Bernd Bartmann
no flags Details
output of "cat /proc/net/dev" (2.38 KB, text/plain)
2002-02-24 12:47 EST, Bernd Bartmann
no flags Details

  None (edit)
Description Bernd Bartmann 2001-11-17 14:46:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [de] (X11; U; Linux 2.4.9-13 i686)

Description of problem:
ifconfig prints strange results for isdn devices. Every isdn devices is
listed twice. The first time including RX/TX packets and bytes and the
second without these statistics.
I have attached the output of the ifconfig, route and ip commands

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. setup an isdn device
2. see the output from "ifconfig"
3.
	

Additional info:
Comment 1 Bernd Bartmann 2001-11-17 14:48:49 EST
Created attachment 37822 [details]
Output of ifconfig, route and ip command
Comment 2 Phil Knirsch 2002-02-24 12:20:41 EST
With 12 interfaces this sounds like a multiport ISDN card. I suspect it might be
 a problem in the driver as this card probably hasn't had the extensive public
tests of the popular AVM Fritz or Teles cards. And i am pretty sure we don't
have such a card to test/verify this problem, so i'd recommend to ask your card
vendor if this might be a know problem to them and if there are updated drivers.

You can also always use the latest errata kernels, they often contain never
versions of drivers as well.

Interessting would be the output of /proc/net/dev on that machine as well...

Read ya, Phil
Comment 3 Bernd Bartmann 2002-02-24 12:46:34 EST
This is not a multiport card at all. It's a normal AVM FritzCard PCI. I use the
12 connections for remote administration purposes. So it is not necessary for me
to have 12 simultaneous connections, I only need the 12 logical connections. I'm
always running the latest errata kernels (now 2.4.9-21).
I will attach the output of /proc/net/dev as requested by you.
Comment 4 Bernd Bartmann 2002-02-24 12:47:32 EST
Created attachment 46541 [details]
output of "cat /proc/net/dev"
Comment 5 Phil Knirsch 2002-02-24 12:53:39 EST
How did you set up the 12 logical interfaces? Using ip or ifconfig?

Another thing would be to try to set up other logical interfaces for e.g. your
ethernet interface and see if the same thing happens there. The we could be sure
it's not a ISDN only problem but maybe something generally broken for logical
interfaces in ifconfig.

Read ya, Phil

PS: As a general rule: We indirectly deprecate the use of ifconfig as ip is the
actively maintained successor of it. Nonetheless, ifconfig shouldn't output all
your isdn cards twice :-)
Comment 6 Bernd Bartmann 2002-02-24 13:21:05 EST
The interfaces are setup using the normal Red Hat init scripts. I just put the
interface descriptions in /etc/sysconfig/networking/devices and after system
boot everything is working fine besides the missing static routes for the ISDN
interfaces (reported as another bug) and the double entries in the ifconfig
output.
What do you mean by logical interfaces for ethernet? Aliases? ISDN and ethernet
are handled completely different by the kernel in terms of physical/logical
connections.
Comment 7 Phil Knirsch 2004-01-12 06:54:23 EST
This bug should now be fixed in the latest rawhide versions of
net-tools. Please verify.

Thanks,

Read ya, Phil
Comment 8 Bernd Bartmann 2004-01-12 17:37:08 EST
Hard to test as I don't have any RHL 7.2 system with ISDN anymore. I
can't reproduce the problem on RHL 9 or later.
Comment 9 Phil Knirsch 2004-02-02 09:35:43 EST
OK, closing the bug as current release then. :-)

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.