Bug 56432 - Unable to load the "aspell" module.
Unable to load the "aspell" module.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: pspell (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-17 20:03 EST by John Davidson
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-19 17:15:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Davidson 2001-11-17 20:03:37 EST
From Bugzilla Helper:

User-Agent: Mozilla/4.0 (compatible; MSIE 5.12; Mac_PowerPC)



Description of problem:

Wen trying to use the pspell libraries I get the following errors: 
Unable to load the "aspell" module.  I first noticed the problem when 
trying to use pspell in PHP but the error alos occuers when using the 
example programs included with the source pspell distribution.



Version-Release number of selected component (if applicable):
0.11.2




How reproducible:

Always



Steps to Reproduce:

1. I was origionally trying to use pspell in PHP, but more simply I 
downloaded the 0.11.2 pspell source (the same one used in the 
RPM)

2.Configured it and then made the example program (cxx) (in the 
examples directory)

3.When you try to run it, it gives the error. (PHP gives the exact same 
error).

	



Actual Results:  I got the error: Unable to load the "aspell" module.



Expected Results:  It should load the aspell module and allow for 
spell checking.



Additional info:



I know the pspell stuff works just fine on 7.2, but that's got newer 
version of almost everything.  I will try to get the newer versions of the 
pspell and aspell RPMs from 7.2 to work on 7.1 and see what 
happens.  But out of the box, pspell does not seem to be working like 
it should.  Aspell seems to work just fine on its own (I can spell check 
text files and what no just fine).
Comment 1 Trond Eivind Glomsrxd 2001-11-19 12:44:26 EST
Do you have pspell-devel and aspell-devel installed?
Comment 2 John Davidson 2001-11-19 12:56:47 EST
Yes.  Everything compiles just fine, I just get that error when I try to use
anything compiled with pspell.  Also, I spent a majority of the weekend
re-compiling the pspell and aspell rpms that come with 7.2 for 7.1.  Pspell
compiled without a hitch, aspell took some work (very little actually, it was an
issue with libtools).  Anyway, after re-compiling them and then installing them
anything I now compile with pspell support works just fine.  For example PHP
compiled with pspell support is now able to check spelling just fine.
Comment 3 Trond Eivind Glomsrxd 2001-11-19 15:09:32 EST
The reason I asked was that the -devel packages contains the libtool .la files.
pspell/aspell is about the only thing I've seen which sometimes needs these to
work properly - this was added to the main packages for RHL 7.2, so I assume
it's fixed now (your recompiles working is an indication of this)
Comment 4 John Davidson 2001-11-19 17:14:57 EST
So you are telling me that I need to upgrade all my 7.1 boxes to 7.2 in order to
fix this?  I am not sure that what I am saying is being understood.  On RedHat
7.1 (with all applicable updates) pspell does not work, when I try to compile
anything to use pspell, even the pspell example scripts (keep in mind that I
have to install both -devel RPMs from the 7.1 distribution to do this), I get
the error: Unable to load the "aspell" module.  This tells me that something is
wrong with the pspell distribution that comes with 7.1.  Now with that in mind,
I can work around the problem in a rather messy fashion.  I can download the
pspell and aspell SRPMs from the 7.2 distribution, rebuild them (after some
tweeking) for use on 7.1.  I can then (on a 7.1 box) remove all dependancies on
the old pspell and aspell (which there are a few) and install my new RPMs (the
ones based on the 7.2 build) and then compile anything to use pspell and they
work like they should.  Isn't this a problem that should be fixed in 7.1?
Comment 5 Trond Eivind Glomsrxd 2002-07-29 16:00:45 EDT
Closing, as this was fixed in RHL 7.2.

Note You need to log in before you can comment on or make changes to this bug.