Bug 56437 - RFE: Xconfigurator fails to configure the GMX2000 card
RFE: Xconfigurator fails to configure the GMX2000 card
Status: CLOSED DUPLICATE of bug 58532
Product: Red Hat Linux Beta
Classification: Retired
Component: redhat-config-xfree86 (Show other bugs)
beta5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Larsson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-18 07:57 EST by Alan Cox
Modified: 2007-04-18 12:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-02 17:08:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2001-11-18 07:57:58 EST
The GMX2000 is a Glint card with 4 chips on it

- A 1Mb VGA compatible Permedia
- A Glint GAMMA G1 hardware OpenGL engine
- A pair of Glint MX rasterisers

All 4 have the PCI subsystem id of 3D Labs 0106. All are functions on the
same PCI identifier

For this device XConfigurator needs to skip the Permedia and configure the
GAMMA G1. It also needs to insert a BusID "PCI:x:y:z" statement. The card
cannot (for complicated reasons) handle 1400 pixels wide modes. It also
needs to the top vertical refresh capping at 76Hz or so.

There are a few other GAMMA/DELTA variants around which have similar
properties. Fortunately (for you anyway) they are all quite uncommon cards.

(I believe Doug used to and may still have a GMX2000 in the lab)
Comment 1 Mike A. Harris 2001-11-19 17:30:16 EST
Ok..  Doug Ledford?
Comment 2 Mike A. Harris 2002-02-09 10:54:10 EST
Doug, I presume Alan is refering to you...  DO you have one
of these cards with which to use for testing?
Comment 3 Doug Ledford 2002-02-13 17:23:08 EST
IF I did (and I seem to recall that I might have) it was either given to the
test lab (in which case Dave Lawrence might know how to find it) or to Michael
Johnson when I went back to being a coder from being a manager.
Comment 4 Mike A. Harris 2002-07-26 09:07:47 EDT
Reassigned to new X config tool for possible future enhancement.
Comment 5 Alan Cox 2002-09-02 17:08:40 EDT
The new tools get this wrong as well. If you want to feed me some updates to try
or want config/tests let me know
Comment 6 Alexander Larsson 2002-10-02 03:19:02 EDT

*** This bug has been marked as a duplicate of 58532 ***

Note You need to log in before you can comment on or make changes to this bug.