Bug 564385 - Kernel panic when root is on LVM2-Volume
Kernel panic when root is on LVM2-Volume
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-12 10:47 EST by Thomas Schweikle
Modified: 2010-06-22 17:28 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-22 17:28:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kernel panic (24.18 KB, image/png)
2010-02-12 10:47 EST, Thomas Schweikle
no flags Details

  None (edit)
Description Thomas Schweikle 2010-02-12 10:47:25 EST
Created attachment 390512 [details]
Kernel panic

Description of problem:
Kernel panic when root is on LVM2-Volume

Version-Release number of selected component (if applicable):
rawhide
lvm2-libs-2.02.60-4.fc13.i686
lvm2-2.02.60-4.fc13.i686
kernel-2.6.33-0.40.rc7.git0.fc13.i686

How reproducible:
Every time

Steps to Reproduce:
1. Install Fedora 12 on an LVM2-Volume mounted as "/"
2. Upgrade to "rawhide"
3. Watch the new kernel panic "Root" not found.
  
Actual results:
Kernel panic, because "root" not found.


Expected results:
Boot

Additional info:
Comment 1 Thomas Schweikle 2010-02-12 10:59:32 EST
root@tali ~ # fdisk -l

Platte /dev/sda: 12.9 GByte, 12884901888 Byte
255 Köpfe, 63 Sektoren/Spur, 1566 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes
Sector size (logical/physical): 512 bytes / 512 bytes
Disk identifier: 0xbe461ec0

   Gerät  boot.     Anfang        Ende     Blöcke   Id  System
/dev/sda1   *           1          42      337333+  83  Linux
/dev/sda2              43        1566    12241530   8e  Linux LVM

Platte /dev/dm-0: 12.5 GByte, 12532580352 Byte
255 Köpfe, 63 Sektoren/Spur, 1523 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes
Sector size (logical/physical): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Festplatte /dev/dm-0 enthält keine gültige Partitionstabelle
Comment 2 Thomas Schweikle 2010-02-12 11:00:41 EST
root@tali ~ # lvdisplay
  --- Logical volume ---
  LV Name                /dev/VolGroup00/LogVol00
  VG Name                VolGroup00
  LV UUID                nQDRTp-6JUu-6cFr-OVSh-Ulny-w7rr-jB3l9Y
  LV Write Access        read/write
  LV Status              available
  # open                 1
  LV Size                11,67 GiB
  Current LE             2988
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           253:0
Comment 3 Bug Zapper 2010-03-15 10:32:23 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Milan Broz 2010-06-22 17:28:08 EDT
This happens when device is not available during lvm scan (missing module in initramfs or some kernel problem).

If it is still reproducible, please reopen the bug and add more info (remove quiet option from kernel boot, if needed) and check if /dev/sda device is recognized before lvm scan.

(I think this was just some temporary problem with dracut & initramfs, this works here without problem.)

Note You need to log in before you can comment on or make changes to this bug.