Bug 564406 - kopete-cryptography FTBFS against kdepim-4.4.0
kopete-cryptography FTBFS against kdepim-4.4.0
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kopete-cryptography (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
: 564980 (view as bug list)
Depends On:
Blocks: kde-4.4 F13FTBFS
  Show dependency treegraph
 
Reported: 2010-02-12 11:38 EST by Rex Dieter
Modified: 2010-02-15 09:17 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-13 16:55:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2010-02-12 11:38:13 EST
In short, kopete-cryptography-1.3.0-kde4.4.0 uses libkeo headers that are no longer exported by kdepim.

krop in #kontact suggested : "drop the kopete-cryptography packaging"

Unfortunately, I see no alternative at the moment.
Comment 1 Kevin Kofler 2010-02-12 16:21:34 EST
Leave it as is for now (i.e. leave the previous build in), I'll look into this tomorrow.
Comment 2 Kevin Kofler 2010-02-13 06:43:55 EST
The offending kdepim commit to revert:
http://websvn.kde.org/?view=revision&revision=1070773
(and we'll need to reenable our kdepim-devel package too).
Comment 3 Kevin Kofler 2010-02-13 12:44:28 EST
*** Bug 564980 has been marked as a duplicate of this bug. ***
Comment 4 Kevin Kofler 2010-02-13 15:52:36 EST
Actually, this is the 4.4 branch commit I'm reverting:
http://websvn.kde.org/?view=revision&revision=1072331
Comment 5 Kevin Kofler 2010-02-13 16:55:43 EST
Fixed in kdepim-4.4.0-4.fc1[123]. kopete-cryptography-1.3.0-16.fc13 built successfully.
Comment 6 Jaroslav Reznik 2010-02-15 08:34:10 EST
Kevin,
thanks for taking care.

Do we have reply from upstream?
Comment 7 Kevin Kofler 2010-02-15 09:17:37 EST
Sadly, no really helpful one. :-( There were 2 suggestions:
(a) drop kopete-cryptography packaging entirely. Huh? They won't even support software in extragear anymore?!
(b) copy the libkleo headers into kopete-cryptography. This is just wrong for several reasons:
1. It's not in kopete-cryptography upstream. We'd have to patch it (also hack the CMakeLists.txt, not just add the headers).
2. Bundling the header probably also means bundling the library or we'll be doing the "build against private header, link against public copy" hack which is quite dangerous if they get out of sync.
3. Bundled libraries (or even just parts of libraries, e.g. header files) suck and violate our packaging guidelines.
So both (a) and (b) look like "no go" to me.
IMHO it's unacceptable that kdepim stops exporting an API which is used by an extragear application.

Note You need to log in before you can comment on or make changes to this bug.