Bug 56442 - gdmconfig basic option to set background does not work
gdmconfig basic option to set background does not work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gdm (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-18 12:05 EST by Joe Acosta
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-26 09:53:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joe Acosta 2001-11-18 12:05:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
It seems that if I use gdmconfig to set the background it flashes the new
color i choose but does not set it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start gdmconfig as root
2.click on the basic option
3.click on the background tab
4.change the background color.  
5. save settings and then logout of X
6. the new login screen color will be the default, but you can watch it
flash your choosen color (I get a purple flash)
	

Additional info:
Comment 1 Joe Acosta 2001-11-20 00:34:30 EST
I found out this happens if you set the background program to something like
xsri which ALSO can set the background color.  So then the real question is why
can a user set the background with xsri AND the color selection widget?  The fix
would be that if one was enabled then the other would be disabled.  I.E. If
someone selects the color radio button then then should not be able to select
the background program as well.
Comment 2 George Lebl 2001-11-21 22:18:12 EST
Well the background program could draw only part of the screen so ...  Anyway,
this is all because RedHat's configuration is on crack and sets that ugly UGLY
xsri hack on the background, when they could add a nice logo on the login
window.

I suppose there might be some warning or some such when you have a background
proggie set.  I'm not sure how to handle this in a nice UI way.  So for now I
resign myself to just bitching about redhat's default configuration.  :)
Comment 3 Havoc Pennington 2002-02-11 18:13:50 EST
We're losing the xsri (at least it appears so at this point). If we don't, I
don't really know how to fix this either, so.

Note You need to log in before you can comment on or make changes to this bug.