Bug 56452 - Need to handle invalid data in lilo.conf better on upgrades
Summary: Need to handle invalid data in lilo.conf better on upgrades
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 61590
TreeView+ depends on / blocked
 
Reported: 2001-11-18 22:52 UTC by stuart boreen
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:48:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump to floppy from failed upgrade (96.76 KB, text/plain)
2001-11-18 22:54 UTC, stuart boreen
no flags Details
lilo.conf from before upgrade (488 bytes, text/plain)
2001-11-29 23:25 UTC, stuart boreen
no flags Details
lilo.conf.anaconda (249 bytes, text/plain)
2001-11-29 23:29 UTC, stuart boreen
no flags Details

Description stuart boreen 2001-11-18 22:52:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4)
Gecko/20011019 Netscape6/6.2

Description of problem:
I tried to upgrade a laptop running 7.1 booting with lilo
to 7.2 booting with grub  All went ok until the last pkg was being written
and I got a crash and I saved to floppy for you

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:

The laptop is an IBM A22  mod 2628
Works great!
I tried again to install. I only needed to upgrade 1 pkg and it went fine
and I got to install the boot loader and it is running now.

Comment 1 stuart boreen 2001-11-18 22:54:24 UTC
Created attachment 37903 [details]
anaconda dump to floppy from failed upgrade

Comment 2 Brent Fox 2001-11-29 15:31:33 UTC
katzj, any ideas here?

Comment 3 Jeremy Katz 2001-11-29 15:41:51 UTC
You don't happen to have a copy of the /etc/lilo.conf from prior to the upgrade
would you?  (it would have been /etc/lilo.conf.rpmsave, but that probably got
overwritten on the second upgrade)

Comment 4 stuart boreen 2001-11-29 23:25:21 UTC
Created attachment 39104 [details]
lilo.conf from before upgrade

Comment 5 stuart boreen 2001-11-29 23:28:38 UTC
lilo.conf from before backup is available. I was using lilo and had made a
custom 2.4.8 kernel. With the install I took RedHat's advice and migrated to
grub -- still keeping grub on the 1st sector of boot partition, not the MBR due
to sharing with Win2000
I will also show you the lilo.anaconda

Comment 6 stuart boreen 2001-11-29 23:29:44 UTC
Created attachment 39105 [details]
lilo.conf.anaconda

Comment 7 Paul Wouters 2002-02-10 17:13:54 UTC
A similar problem is when doing a "fresh" install over a previous install.
If you used lilo on the previous redhat, and install grub, the MBR doesn't
get wiped, grub goes into the first partition, and at boot it hangs on half
a lilo (LI).


Comment 8 Jeremy Katz 2002-03-15 04:24:15 UTC
The last thing reported we can't do anything about (though we handle upgrade
bootloader stuff differently now).  The others are due to quotes in the
lilo.conf and we handle that better now in CVS

Comment 9 Red Hat Bugzilla 2006-02-21 18:48:15 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.