Bug 564521 - Metric table links throw exception for autogroups
Metric table links throw exception for autogroups
Status: CLOSED WORKSFORME
Product: RHQ Project
Classification: Other
Component: Database (Show other bugs)
1.3
All Linux
high Severity high (vote)
: ---
: ---
Assigned To: John Sanda
Ondřej Žižka
: SubBug
Depends On:
Blocks: rhq_triage jon-sprint10-bugs
  Show dependency treegraph
 
Reported: 2010-02-12 18:38 EST by Ondřej Žižka
Modified: 2010-05-20 06:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-20 06:55:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
HQL stacktrace (52.40 KB, text/html)
2010-02-12 18:40 EST, Ondřej Žižka
no flags Details
JSP stacktrace (5.85 KB, text/html)
2010-02-12 18:42 EST, Ondřej Žižka
no flags Details
HQL error page (186.42 KB, text/html)
2010-02-12 18:46 EST, Ondřej Žižka
no flags Details
Prev page screenshot (just to make sure :) (43.64 KB, image/png)
2010-02-12 18:47 EST, Ondřej Žižka
no flags Details

  None (edit)
Description Ondřej Žižka 2010-02-12 18:38:58 EST
Happens when clicking a link in a metrics table of an autogroup:

1) Click on some agent's autogroup, e.g. File System
2) Go to MONITOR / TABLES
3) Click some link.
4) You'll get the page with report about HQL syntax error.

org.hibernate.hql.ast.QuerySyntaxException: unexpected end of subtree [SELECT ms FROM org.rhq.core.domain.measurement.MeasurementSchedule ms WHERE ms.definition.id IN (:definitionIds) AND ms.resource.id IN ()]

Full stack trace attached.
Comment 1 Ondřej Žižka 2010-02-12 18:40:37 EST
Created attachment 390605 [details]
HQL stacktrace
Comment 2 Ondřej Žižka 2010-02-12 18:42:52 EST
Created attachment 390606 [details]
JSP stacktrace
Comment 3 Ondřej Žižka 2010-02-12 18:46:15 EST
Created attachment 390607 [details]
HQL error page
Comment 4 Ondřej Žižka 2010-02-12 18:47:12 EST
Created attachment 390608 [details]
Prev page screenshot (just to make sure :)
Comment 5 wes hayutin 2010-02-16 11:56:30 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 6 wes hayutin 2010-02-16 12:01:43 EST
making sure we're not missing any bugs in rhq_triage
Comment 7 John Sanda 2010-05-20 06:55:08 EDT
I tested this with a tomcat war autogroup from an EWS installation running on a F12 box, similar to the screenshot provided in commnent 4. I was unable to reproduce this bug. I am closing this out as it appears to have been resolved since it was originally reported.

Note You need to log in before you can comment on or make changes to this bug.