Bug 564539 - Tomcat plugin: WAR's Installation Date displays bogus value
Tomcat plugin: WAR's Installation Date displays bogus value
Status: CLOSED WORKSFORME
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
1.3
All Linux
low Severity high (vote)
: ---
: ---
Assigned To: Ondřej Žižka
Mike Foley
: SubBug
Depends On:
Blocks: ews1.0.2 rhq_triage
  Show dependency treegraph
 
Reported: 2010-02-12 22:50 EST by Ondřej Žižka
Modified: 2011-10-24 13:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-24 13:09:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ondřej Žižka 2010-02-12 22:50:57 EST
According to JON, I've installed servlet-examples on my Tomcat 40 years ago, which is kind of scarry, I thought it was yesterday.

Now seriously: 

1) Tomcat (8080) > Tomcat VHost (localhost) > Tomcat WAR (/servlets-examples)
2) CONTENT / DEPLOYED
3) See: servlets-examples	1.0	WAR File	14653 days, 3 hours ago
Comment 1 Ondřej Žižka 2010-02-12 22:55:31 EST
Ah, it's the UNIX epoch. Somewhere is missing if( date == 0 ){ ... }
Comment 2 wes hayutin 2010-02-16 11:52:24 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 3 wes hayutin 2010-02-16 11:58:11 EST
making sure we're not missing any bugs in rhq_triage
Comment 4 Corey Welton 2010-09-30 09:55:01 EDT
possibly a dupe, will try to find the other one.
Comment 5 Stefan Negrea 2011-10-17 21:23:56 EDT
From the replication steps, I inferred the usage of Tomcat 5.5.x since servlet-examples is not delivered with Tomcat 6.0.x. 

I retested the ticket with Tomcat 5.5.33 on both Windows and Linux but I could not replicate the problem. The date for the deployed content is the date I actually installed the Tomcat server.

Please retest and update the replication steps if the problem is still present.
Comment 6 Ondřej Žižka 2011-10-18 02:45:32 EDT
Stefan, please try with Red Hat EWS product if you can.
http://porkchop.devel.redhat.com/devel/candidates/JBEWS/

Since this bug is 1.5 y/o, that would be EWS 1.0.1 I guess. But I'd try with the latest, i.e. 1.0.2.

Note You need to log in before you can comment on or make changes to this bug.