Bug 564539 - Tomcat plugin: WAR's Installation Date displays bogus value
Summary: Tomcat plugin: WAR's Installation Date displays bogus value
Status: CLOSED WORKSFORME
Alias: None
Product: RHQ Project
Classification: Other
Component: Plugins
Version: 1.3
Hardware: All
OS: Linux
low
high vote
Target Milestone: ---
: ---
Assignee: Ondřej Žižka
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords: SubBug
Depends On:
Blocks: ews1.0.2 rhq_triage
TreeView+ depends on / blocked
 
Reported: 2010-02-13 03:50 UTC by Ondřej Žižka
Modified: 2011-10-24 17:09 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-10-24 17:09:30 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 588507 None None None Never

Internal Trackers: 588507

Description Ondřej Žižka 2010-02-13 03:50:57 UTC
According to JON, I've installed servlet-examples on my Tomcat 40 years ago, which is kind of scarry, I thought it was yesterday.

Now seriously: 

1) Tomcat (8080) > Tomcat VHost (localhost) > Tomcat WAR (/servlets-examples)
2) CONTENT / DEPLOYED
3) See: servlets-examples	1.0	WAR File	14653 days, 3 hours ago

Comment 1 Ondřej Žižka 2010-02-13 03:55:31 UTC
Ah, it's the UNIX epoch. Somewhere is missing if( date == 0 ){ ... }

Comment 2 wes hayutin 2010-02-16 16:52:24 UTC
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug

Comment 3 wes hayutin 2010-02-16 16:58:11 UTC
making sure we're not missing any bugs in rhq_triage

Comment 4 Corey Welton 2010-09-30 13:55:01 UTC
possibly a dupe, will try to find the other one.

Comment 5 Stefan Negrea 2011-10-18 01:23:56 UTC
From the replication steps, I inferred the usage of Tomcat 5.5.x since servlet-examples is not delivered with Tomcat 6.0.x. 

I retested the ticket with Tomcat 5.5.33 on both Windows and Linux but I could not replicate the problem. The date for the deployed content is the date I actually installed the Tomcat server.

Please retest and update the replication steps if the problem is still present.

Comment 6 Ondřej Žižka 2011-10-18 06:45:32 UTC
Stefan, please try with Red Hat EWS product if you can.
http://porkchop.devel.redhat.com/devel/candidates/JBEWS/

Since this bug is 1.5 y/o, that would be EWS 1.0.1 I guess. But I'd try with the latest, i.e. 1.0.2.


Note You need to log in before you can comment on or make changes to this bug.