Bug 564598 - FTBFS compat-libgda-3.1.2-3.fc12: ImplicitDSOLinking
FTBFS compat-libgda-3.1.2-3.fc12: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: compat-libgda (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245 583274
  Show dependency treegraph
 
Reported: 2010-02-13 11:20 EST by FTBFS
Modified: 2010-11-18 16:34 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-02 21:43:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (214.46 KB, text/plain)
2010-02-13 11:20 EST, FTBFS
no flags Details
build.log (329.86 KB, text/plain)
2010-02-13 11:20 EST, FTBFS
no flags Details
mock.log (975 bytes, text/plain)
2010-02-13 11:20 EST, FTBFS
no flags Details
root.log (287.83 KB, text/plain)
2010-02-13 11:20 EST, FTBFS
no flags Details
build.log (323.92 KB, text/plain)
2010-02-13 11:20 EST, FTBFS
no flags Details
mock.log (983 bytes, text/plain)
2010-02-13 11:20 EST, FTBFS
no flags Details
Upstream patch (609 bytes, patch)
2010-03-23 04:05 EDT, Bruno Wolff III
no flags Details | Diff
This patch fixes the fedora build (531 bytes, patch)
2010-03-23 04:07 EDT, Bruno Wolff III
no flags Details | Diff

  None (edit)
Description FTBFS 2010-02-13 11:20:12 EST
compat-libgda-3.1.2-3.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 11:20:15 EST
Created attachment 390648 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 11:20:17 EST
Created attachment 390649 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 11:20:18 EST
Created attachment 390650 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 11:20:19 EST
Created attachment 390651 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 11:20:20 EST
Created attachment 390652 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 11:20:21 EST
Created attachment 390653 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:33:12 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bruno Wolff III 2010-03-23 04:05:10 EDT
Created attachment 401953 [details]
Upstream patch

This is what I think is need to fix the root cause and should be sent upstream if this version is still getting updates.
Comment 9 Bruno Wolff III 2010-03-23 04:07:44 EDT
Created attachment 401954 [details]
This patch fixes the fedora build

Since autotools isn't run as part of the build the Makefile.in file needs to be fixed for the Fedora build. I tested this with a modified tar archive. You'd need to reference this patch in the spec file to get it to work.
Comment 10 Nick Bebout 2010-06-02 21:43:20 EDT
I applied this patch and built it for F-13 and devel.  I did not push updates in bodhi, Let me know if I need to.  (I'm not the maintainer, I just committed it as a provenpackager).

Note You need to log in before you can comment on or make changes to this bug.