Bug 564599 - FTBFS resapplet-0.1.1-9.fc12: ImplicitDSOLinking
FTBFS resapplet-0.1.1-9.fc12: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: resapplet (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Radek Vokal
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245
  Show dependency treegraph
 
Reported: 2010-02-13 11:20 EST by FTBFS
Modified: 2010-03-23 09:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-23 09:29:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (769.46 KB, text/plain)
2010-02-13 11:20 EST, FTBFS
no flags Details
build.log (21.29 KB, text/plain)
2010-02-13 11:20 EST, FTBFS
no flags Details
mock.log (1.01 KB, text/plain)
2010-02-13 11:20 EST, FTBFS
no flags Details
root.log (1.13 MB, text/plain)
2010-02-13 11:20 EST, FTBFS
no flags Details
build.log (21.03 KB, text/plain)
2010-02-13 11:20 EST, FTBFS
no flags Details
mock.log (967 bytes, text/plain)
2010-02-13 11:20 EST, FTBFS
no flags Details
Upstream patch for am version of Makefile (245 bytes, patch)
2010-03-23 04:40 EDT, Bruno Wolff III
no flags Details | Diff
Patch that adds -lX11 so that the package builds (274 bytes, patch)
2010-03-23 04:43 EDT, Bruno Wolff III
no flags Details | Diff

  None (edit)
Description FTBFS 2010-02-13 11:20:23 EST
resapplet-0.1.1-9.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 11:20:26 EST
Created attachment 390654 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 11:20:27 EST
Created attachment 390655 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 11:20:28 EST
Created attachment 390656 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 11:20:30 EST
Created attachment 390657 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 11:20:31 EST
Created attachment 390658 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 11:20:32 EST
Created attachment 390659 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:33:19 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bruno Wolff III 2010-03-23 04:40:01 EDT
Created attachment 401966 [details]
Upstream patch for am version of Makefile

This one should go upstream so that when autoconf is used a good Makefile.in is made.
Comment 9 Bruno Wolff III 2010-03-23 04:43:09 EDT
Created attachment 401967 [details]
Patch that adds -lX11 so that the package builds

I think this is good enough and probably a more complicated search for where the X11 stuff is isn't needed or is implied when looking for xrandr.
The spec file will need to be modified to refer to this patch.
Comment 10 Radek Vokal 2010-03-23 09:29:12 EDT
Thanks a lot. Since the %build runs autoconf, the second patch doesn't make much sense and the first one should do it. It's in rawhide.

Note You need to log in before you can comment on or make changes to this bug.