This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 564609 - FTBFS liferea-1.6.2-2.fc13: ImplicitDSOLinking
FTBFS liferea-1.6.2-2.fc13: ImplicitDSOLinking
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: liferea (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245
  Show dependency treegraph
 
Reported: 2010-02-13 11:22 EST by FTBFS
Modified: 2010-04-20 09:36 EDT (History)
2 users (show)

See Also:
Fixed In Version: liferea-1.6.3-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-27 15:38:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (793.06 KB, text/plain)
2010-02-13 11:22 EST, FTBFS
no flags Details
build.log (183.02 KB, text/plain)
2010-02-13 11:22 EST, FTBFS
no flags Details
mock.log (1.00 KB, text/plain)
2010-02-13 11:22 EST, FTBFS
no flags Details
root.log (1.11 MB, text/plain)
2010-02-13 11:22 EST, FTBFS
no flags Details
build.log (180.15 KB, text/plain)
2010-02-13 11:22 EST, FTBFS
no flags Details
mock.log (1.01 KB, text/plain)
2010-02-13 11:22 EST, FTBFS
no flags Details
Patch for Makefile.in (345 bytes, patch)
2010-03-27 14:06 EDT, Bruno Wolff III
no flags Details | Diff
This patch should go to the upstream Makefile.am (343 bytes, patch)
2010-03-27 14:07 EDT, Bruno Wolff III
no flags Details | Diff

  None (edit)
Description FTBFS 2010-02-13 11:22:05 EST
liferea-1.6.2-2.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 11:22:08 EST
Created attachment 390711 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 11:22:09 EST
Created attachment 390712 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 11:22:10 EST
Created attachment 390713 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 11:22:12 EST
Created attachment 390714 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 11:22:13 EST
Created attachment 390715 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 11:22:14 EST
Created attachment 390716 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:33:52 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bruno Wolff III 2010-03-27 14:06:02 EDT
Created attachment 403022 [details]
Patch for Makefile.in

This patch should get liferea to build again on F13. -lX11 needs to get added.
Comment 9 Bruno Wolff III 2010-03-27 14:07:26 EDT
Created attachment 403023 [details]
This patch should go to the upstream Makefile.am

This is the previous fix applied to Makefile.am which is used by upstream to build Makefile.in.
Comment 10 Bruno Wolff III 2010-03-27 15:38:56 EDT
I see that liferea has been rebuilt in F13.
Thanks for finishing up with this!
Comment 11 Fedora Update System 2010-03-27 17:13:37 EDT
liferea-1.6.3-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/liferea-1.6.3-1.fc13
Comment 12 Fedora Update System 2010-04-20 09:36:19 EDT
liferea-1.6.3-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.