Bug 564611 - FTBFS blobby-0.6-0.13.a.fc12: ImplicitDSOLinking
FTBFS blobby-0.6-0.13.a.fc12: ImplicitDSOLinking
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: blobby (Show other bugs)
13
i386 Linux
high Severity high
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245
  Show dependency treegraph
 
Reported: 2010-02-13 11:22 EST by FTBFS
Modified: 2010-03-23 01:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-23 01:33:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (533.20 KB, text/plain)
2010-02-13 11:22 EST, FTBFS
no flags Details
build.log (110.37 KB, text/plain)
2010-02-13 11:22 EST, FTBFS
no flags Details
mock.log (956 bytes, text/plain)
2010-02-13 11:22 EST, FTBFS
no flags Details
blobby FTBFS patch (1.06 KB, patch)
2010-02-19 06:33 EST, Ankur Sinha (FranciscoD)
no flags Details | Diff
spec patch (1.08 KB, patch)
2010-02-19 06:35 EST, Ankur Sinha (FranciscoD)
no flags Details | Diff

  None (edit)
Description FTBFS 2010-02-13 11:22:27 EST
blobby-0.6-0.13.a.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 11:22:30 EST
Created attachment 390723 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 11:22:32 EST
Created attachment 390724 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 11:22:33 EST
Created attachment 390725 [details]
mock.log

mock.log for i386
Comment 4 Ankur Sinha (FranciscoD) 2010-02-19 06:33:07 EST
Created attachment 395073 [details]
blobby FTBFS patch

blobby patch for lpthread implicit DSO linkage
Comment 5 Ankur Sinha (FranciscoD) 2010-02-19 06:35:09 EST
Created attachment 395075 [details]
spec patch
Comment 6 Bug Zapper 2010-03-15 10:33:59 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bruno Wolff III 2010-03-23 01:33:47 EDT
This package has been successfully built from source in f12, f13 and f14 since the ticket was filed.

Note You need to log in before you can comment on or make changes to this bug.