Bug 564614 - FTBFS enlightenment-0.16.999.050-5.fc12: ImplicitDSOLinking
FTBFS enlightenment-0.16.999.050-5.fc12: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: enlightenment (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Thomas Janssen
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245
  Show dependency treegraph
 
Reported: 2010-02-13 11:22 EST by FTBFS
Modified: 2010-04-04 11:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-04 11:27:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (749.13 KB, text/plain)
2010-02-13 11:22 EST, FTBFS
no flags Details
build.log (137.70 KB, text/plain)
2010-02-13 11:22 EST, FTBFS
no flags Details
mock.log (1.05 KB, text/plain)
2010-02-13 11:22 EST, FTBFS
no flags Details
root.log (999.07 KB, text/plain)
2010-02-13 11:22 EST, FTBFS
no flags Details
build.log (129.31 KB, text/plain)
2010-02-13 11:22 EST, FTBFS
no flags Details
mock.log (1004 bytes, text/plain)
2010-02-13 11:22 EST, FTBFS
no flags Details
Patch for Makefile.in (469 bytes, patch)
2010-03-27 15:16 EDT, Bruno Wolff III
no flags Details | Diff
Patch for Makefile.am (454 bytes, patch)
2010-03-27 15:18 EDT, Bruno Wolff III
no flags Details | Diff

  None (edit)
Description FTBFS 2010-02-13 11:22:44 EST
enlightenment-0.16.999.050-5.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 11:22:47 EST
Created attachment 390732 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 11:22:49 EST
Created attachment 390733 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 11:22:50 EST
Created attachment 390734 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 11:22:51 EST
Created attachment 390735 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 11:22:52 EST
Created attachment 390736 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 11:22:54 EST
Created attachment 390737 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:34:13 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bruno Wolff III 2010-03-27 15:16:11 EDT
Created attachment 403028 [details]
Patch for Makefile.in

e_border needs something from libm and the build for that part of the package doesn't reference it explicitly, so the build will fail on F13.
There were a few collections of linker options and I may not have picked the best place for this addition. It does seem to build now though.
Comment 9 Bruno Wolff III 2010-03-27 15:18:12 EDT
Created attachment 403029 [details]
Patch for Makefile.am

While Makefile.am isn't used for Fedora builds, upstream should apply an appropriate patch so that when they run automake a fixed Makefile.in gets built.
Comment 10 Fedora Admin XMLRPC Client 2010-03-28 14:49:22 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 11 Thomas Janssen 2010-04-04 11:27:22 EDT
That got pulled into rawhide in the F-13 cycle. I fixed it while i rebuilt the package for F-13.
enlightenment-0.16.999.050-6.fc13

Note You need to log in before you can comment on or make changes to this bug.