Bug 564619 - FTBFS gimmix-0.5.6.1-3.fc13: ImplicitDSOLinking
FTBFS gimmix-0.5.6.1-3.fc13: ImplicitDSOLinking
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gimmix (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245
  Show dependency treegraph
 
Reported: 2010-02-13 11:23 EST by FTBFS
Modified: 2010-04-16 19:30 EDT (History)
2 users (show)

See Also:
Fixed In Version: gimmix-0.5.7.1-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-16 19:30:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (483.72 KB, text/plain)
2010-02-13 11:23 EST, FTBFS
no flags Details
build.log (23.10 KB, text/plain)
2010-02-13 11:23 EST, FTBFS
no flags Details
mock.log (1.01 KB, text/plain)
2010-02-13 11:23 EST, FTBFS
no flags Details
root.log (693.82 KB, text/plain)
2010-02-13 11:23 EST, FTBFS
no flags Details
build.log (22.70 KB, text/plain)
2010-02-13 11:23 EST, FTBFS
no flags Details
mock.log (961 bytes, text/plain)
2010-02-13 11:23 EST, FTBFS
no flags Details
Patch for Makefile.in (265 bytes, patch)
2010-03-27 15:41 EDT, Bruno Wolff III
no flags Details | Diff
Makefile.am patch (217 bytes, patch)
2010-03-27 15:43 EDT, Bruno Wolff III
no flags Details | Diff

  None (edit)
Description FTBFS 2010-02-13 11:23:38 EST
gimmix-0.5.6.1-3.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 11:23:41 EST
Created attachment 390762 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 11:23:42 EST
Created attachment 390763 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 11:23:43 EST
Created attachment 390764 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 11:23:45 EST
Created attachment 390765 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 11:23:46 EST
Created attachment 390766 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 11:23:47 EST
Created attachment 390767 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:34:21 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bruno Wolff III 2010-03-27 15:41:24 EDT
Created attachment 403031 [details]
Patch for Makefile.in

gimmix uses X11 but doesn't explicitly link it, which on F13 breaks builds.
This patch can be applied in Fedora to get it building again.
Comment 9 Bruno Wolff III 2010-03-27 15:43:19 EDT
Created attachment 403032 [details]
Makefile.am patch

While Makefile.am isn't used for Fedora, it is used by upstream to make Makefile.in, so this patch should ideally be sent upstream, so that in the future Makefile.in will be OK.
Comment 10 Andreas Bierfert 2010-03-28 11:58:49 EDT
Thanks for providing the patches. Did not have time to look into it myself.
Comment 11 Fedora Update System 2010-03-28 12:27:26 EDT
gimmix-0.5.7.1-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gimmix-0.5.7.1-1.fc13
Comment 12 Bruno Wolff III 2010-03-28 13:12:23 EDT
I am glad to help. I have volunteered for Fedora Engineering Services and dealing with DSO FTBFS bugs is my first task.
Comment 13 Fedora Update System 2010-04-01 15:34:15 EDT
gimmix-0.5.7.1-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gimmix'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gimmix-0.5.7.1-1.fc13
Comment 14 Fedora Update System 2010-04-16 19:30:22 EDT
gimmix-0.5.7.1-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.